aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2016-05-10 18:54:06 +0200
committerJörg Mayer <jmayer@loplof.de>2016-05-10 17:45:29 +0000
commita9070e1a90713c76af836c50fe381ea1659f768c (patch)
treee44b24b9bb0238d043f686a87cb4d3a36da2644a /CMakeLists.txt
parentb6d838eebf4456192360654092e5587c5207f185 (diff)
When using clang, warn about c99 only syntax (like pedantic without all the rest).
Change-Id: Ife6fcb14ce04e4d505ee4911a102420932fb18de Reviewed-on: https://code.wireshark.org/review/15334 Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4d10b090bf..24094ce8a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -382,6 +382,8 @@ else()
# The Qt headers generate a ton of shortening errors on 64-bit systems
# so only enable this for C for now.
-Wshorten-64-to-32
+ # Clang only
+ -Wc99-extensions
)
set(WIRESHARK_CXX_ONLY_FLAGS