aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGuy Harris <guy@alum.mit.edu>2014-06-18 11:58:04 -0700
committerGuy Harris <guy@alum.mit.edu>2014-06-18 18:58:57 +0000
commit8dabe0027a36aa5e2d95ec6ad724faa973cd1ee7 (patch)
tree4d536e33ef949e03e25c862fe3598c4eaa5ba421 /CMakeLists.txt
parentc6007e8d26a5fc2471242fbe571bf52284beaae3 (diff)
We don't need -Qunused-arguments with Clang
check_c_compiler_flag now checks for the message Clang prints for -f and -m flags it doesn't handle ("argument unused during compilation: '-{flag}'"), so the checks for it now should fail properly during testing, causing us not to use the flag in question. This means we don't need to suppress that warning, as we shouldn't be getting it. Change-Id: Ieb9657f9e2cee2f357acd52725199d78d2dad80f Reviewed-on: https://code.wireshark.org/review/2401 Reviewed-by: Guy Harris <guy@alum.mit.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 802d702cc1..8eb1244ac8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -287,12 +287,8 @@ else()
set(WIRESHARK_EXTRA_COMPILER_CPP_ONLY_FLAGS
)
- # With clang some tests don't fail properly during testing but only
- # during real compiles
-
if(CMAKE_C_COMPILER_ID MATCHES "Clang")
set(WIRESHARK_COMMON_FLAGS ${WIRESHARK_COMMON_FLAGS}
- -Qunused-arguments
#-fcolor-diagnostics
)
else()