aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2014-08-05 13:27:24 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2014-08-05 12:33:28 +0000
commit8b2a8a9636d0909e417112ef2d14601955a1458a (patch)
treeece9c37e1d14e23b273c6981a508be2e3a001bdc /CMakeLists.txt
parent1de0203c5fe8864637821898c393fc01f1e981a1 (diff)
Suppress 10 of the CMP0020 CMake warnings on Windows, only 8 left now.
Change-Id: I2f85529728e0346b8c4888cd1c23e86a306cc613 Reviewed-on: https://code.wireshark.org/review/3430 Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 813f2ee4b3..e21aaf6268 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,10 +31,6 @@ cmake_policy(SET CMP0008 NEW)
cmake_policy(SET CMP0011 OLD)
# Policy since 2.8.1
cmake_policy(SET CMP0015 NEW)
-# Policy since 2.8.11
-if (POLICY CMP0020)
- cmake_policy(SET CMP0020 OLD)
-endif()
#Where to find local cmake scripts
set(CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
@@ -1105,6 +1101,10 @@ if(BUILD_qtshark AND QT_FOUND)
)
# qtshark and wireshark share wireshark_FILES
+ if (POLICY CMP0020)
+ cmake_policy(SET CMP0020 OLD)
+ endif()
+
add_executable(qtshark ${wireshark_FILES})
set_target_properties(qtshark PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
set_target_properties(qtshark PROPERTIES FOLDER "Executables")