aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-10-02 20:50:11 +0000
committerGerald Combs <gerald@wireshark.org>2015-10-02 20:50:20 +0000
commit835cfa50cb3ca1acb9cb600f68231c9e37201a9d (patch)
treefcc77896c2122a0550786c869aeb7fe2209d887c /CMakeLists.txt
parent93d8bbd586c1d6b919d3e4911aca5a9b9b3275de (diff)
Revert "CMake: Don't feed -fPIC to Visual C++."
This doesn't appear to fix the issue unfortunately. This reverts commit fd5eafa50a77bc319a240727600be38307e54f86. Change-Id: Ida25881fca0a667c7d47692465b8f1fc9d335697 Reviewed-on: https://code.wireshark.org/review/10753 Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c704c7e015..9450f67bf5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -873,8 +873,7 @@ if(HAVE_LIBZLIB)
endif()
if (Qt5Widgets_FOUND)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS}")
- if (Qt5_POSITION_INDEPENDENT_CODE AND NOT CMAKE_CXX_COMPILER_ID MATCHES "MSVC")
- # Qt 5.5's Qt5CoreConfigExtras.cmake adds "-fPIC".
+ if (Qt5_POSITION_INDEPENDENT_CODE)
set(CMAKE_POSITION_INDEPENDENT_CODE ON)
endif()
set (QT_FOUND ON)