aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis La Goutte <alexis.lagoutte@gmail.com>2016-03-07 09:33:44 +0100
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2016-03-08 18:02:01 +0000
commit80dda81a61753ceff29820f29b755a61994c0bf5 (patch)
tree123c9d8527c94cbf4f7f9a6b81aa9101c450777a /CMakeLists.txt
parente82bdcb53abde199873be257c32e30b18f16d8aa (diff)
AUTHORS: sort by name
Change-Id: I01980d1ab757decb7bb84649dbd41477978104c3 Reviewed-on: https://code.wireshark.org/review/14381 Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 571cf43fcc..fb36b19a4b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2703,10 +2703,11 @@ add_custom_target(test-sh
DEPENDS ${CMAKE_SOURCE_DIR}/cmake/modules/GenerateTestSh.cmake
)
+#Generate list of AUTHORS (Name + E-Mail) sort by name
if (GIT_EXECUTABLE)
ADD_CUSTOM_TARGET(
gen-authors
- COMMAND ${GIT_EXECUTABLE} --no-pager shortlog -sne HEAD > ${CMAKE_SOURCE_DIR}/AUTHORS.git
+ COMMAND ${GIT_EXECUTABLE} --no-pager shortlog -se HEAD > ${CMAKE_SOURCE_DIR}/AUTHORS.git
COMMAND ${PERL_EXECUTABLE} ${CMAKE_SOURCE_DIR}/tools/generate_authors.pl ${CMAKE_SOURCE_DIR}/AUTHORS.src ${CMAKE_SOURCE_DIR}/AUTHORS.git > ${CMAKE_SOURCE_DIR}/AUTHORS
)
else (GIT_EXECUTABLE)