aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2014-09-05 11:17:17 -0700
committerGerald Combs <gerald@wireshark.org>2014-09-17 20:04:28 +0000
commit7e638057089bb9d599cd35d4673aef70e0ae58a1 (patch)
treece2f546bac9c6c8bcac74b0d5ba0424ddefad0ca /CMakeLists.txt
parent478fab5206bf30a639ec9ba71edff2fb6ec2cad4 (diff)
Qt: Add the "Map" button to the Endpoints dialog.
Move the map creation code from ui/gtk/hostlist_table.c to ui/traffic_table_ui.c. Add CMake commands to copy ipmap.html to the run directory so that WIRESHARK_RUN_FROM_BUILD_DIRECTORY works for the endpoint map. Not sure if they're entirely correct but they appear to work. Add boundary checkes to geoip_db_lookup_ipv[46]. To do: - It looks like there are prettier maps and newer APIs that we might want to use. Change-Id: Ie06992c9bc9c9aa683328aecab3f5f69c9cab966 Reviewed-on: https://code.wireshark.org/review/4011 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt74
1 files changed, 46 insertions, 28 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dd00eed83a..d546a05b07 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1078,7 +1078,7 @@ set(LIBEPAN_LIBS
${WINSPARKLE_LIBRARIES}
)
-if( (BUILD_wireshark_gtk AND GTK_FOUND) OR (BUILD_wireshark AND QT_FOUND) )
+if( (BUILD_wireshark AND QT_FOUND) OR (BUILD_wireshark_gtk AND GTK_FOUND) )
set(WIRESHARK_SRC
capture_info.c
capture_opts.c
@@ -1095,33 +1095,6 @@ if( (BUILD_wireshark_gtk AND GTK_FOUND) OR (BUILD_wireshark AND QT_FOUND) )
)
endif()
-if(BUILD_wireshark_gtk AND GTK_FOUND)
- set(wireshark_gtk_LIBS
- gtkui
- ui
- capchild
- caputils
- ${GTK2_LIBRARIES}
- ${GTK3_LIBRARIES}
- ${GTHREAD2_LIBRARIES}
- codecs
- ${PORTAUDIO_LIBRARIES}
- ${LIBEPAN_LIBS}
- ${APPLE_APPLICATION_SERVICES_LIBRARY}
- ${APPLE_CORE_SERVICES_LIBRARY}
- ${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
- ${NL_LIBRARIES}
- ${WIN_COMCTL32_LIBRARY}
- )
- # wireshark and wireshark-gtk share wireshark_FILES
-
- add_executable(wireshark-gtk ${wireshark_FILES})
- set_target_properties(wireshark-gtk PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
- set_target_properties(wireshark-gtk PROPERTIES FOLDER "Executables")
- target_link_libraries(wireshark-gtk ${wireshark_gtk_LIBS})
- install(TARGETS wireshark-gtk RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
-endif()
-
if(BUILD_wireshark AND QT_FOUND)
set(wireshark_LIBS
qtui
@@ -1149,6 +1122,51 @@ if(BUILD_wireshark AND QT_FOUND)
set_target_properties(wireshark PROPERTIES FOLDER "Executables")
target_link_libraries(wireshark ${wireshark_LIBS})
install(TARGETS wireshark RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+
+ # Map for endpoints dialog
+ ADD_CUSTOM_COMMAND(
+ TARGET wireshark
+ POST_BUILD
+ COMMAND ${CMAKE_COMMAND} -E copy_if_different
+ "${PROJECT_SOURCE_DIR}/ipmap.html"
+ $<TARGET_FILE_DIR:wireshark>
+ )
+endif()
+
+if(BUILD_wireshark_gtk AND GTK_FOUND)
+ set(wireshark_gtk_LIBS
+ gtkui
+ ui
+ capchild
+ caputils
+ ${GTK2_LIBRARIES}
+ ${GTK3_LIBRARIES}
+ ${GTHREAD2_LIBRARIES}
+ codecs
+ ${PORTAUDIO_LIBRARIES}
+ ${LIBEPAN_LIBS}
+ ${APPLE_APPLICATION_SERVICES_LIBRARY}
+ ${APPLE_CORE_SERVICES_LIBRARY}
+ ${APPLE_SYSTEM_CONFIGURATION_LIBRARY}
+ ${NL_LIBRARIES}
+ ${WIN_COMCTL32_LIBRARY}
+ )
+ # wireshark and wireshark-gtk share wireshark_FILES
+
+ add_executable(wireshark-gtk ${wireshark_FILES})
+ set_target_properties(wireshark-gtk PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
+ set_target_properties(wireshark-gtk PROPERTIES FOLDER "Executables")
+ target_link_libraries(wireshark-gtk ${wireshark_gtk_LIBS})
+ install(TARGETS wireshark-gtk RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
+
+ # Map for endpoints dialog
+ ADD_CUSTOM_COMMAND(
+ TARGET wireshark-gtk
+ POST_BUILD
+ COMMAND ${CMAKE_COMMAND} -E copy_if_different
+ "${PROJECT_SOURCE_DIR}/ipmap.html"
+ $<TARGET_FILE_DIR:wireshark-gtk>
+ )
endif()
register_tap_files(tshark-tap-register.c