aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGerald Combs <gerald@wireshark.org>2015-10-15 14:45:45 -0700
committerGerald Combs <gerald@wireshark.org>2015-10-16 20:40:28 +0000
commit7682ae4887fbc45c8d4e3f0d8f21cd9d9093c83b (patch)
treea0aa1521e96a473a8da95d65deb82aa035a12662 /CMakeLists.txt
parent71398e26f7265861e9be75973da6d1aff116e5a8 (diff)
Keep CMake from finding Cygwin's Python.
Try to find Python and set PYTHON_EXECUTABLE on Windows via the registry prior to calling FindPythonInterp. This works around a bug in CMake that prefers Cygwin's Python, which is a symlink, which by default is a text file that contains a Cygwin-specific cookie, which is therefore useless outside of Cygwin. This is avoids the need to pass -DPYTHON_EXECUTABLE=... to CMake. Change-Id: Ife37221b61d920682c20357b6d139a93067a5ad1 Reviewed-on: https://code.wireshark.org/review/11071 Petri-Dish: Gerald Combs <gerald@wireshark.org> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Gerald Combs <gerald@wireshark.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 85d77b73cf..7f234acf28 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -134,6 +134,9 @@ if(WIN32)
endif()
# XXX Add a dependency on ${_ws_lib_dir}/current_tag.txt?
+
+ # Head off any attempts to use Cygwin's Python.
+ include(LocatePythonExecutable)
endif(WIN32)
include(UseCustomIncludes)
@@ -769,10 +772,10 @@ endif()
set(PROGLIST)
-#Sort the package list
+# Sort the package list
list(SORT PACKAGELIST)
message(STATUS "Packagelist: ${PACKAGELIST}")
-#Let's loop the package list
+# Let's loop the package list
foreach(PACKAGE ${PACKAGELIST})
if(${PACKAGE} STREQUAL "Qt4")
set(PACKAGE_VAR "QT")