aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2014-06-16 21:12:30 +0200
committerJörg Mayer <jmayer@loplof.de>2014-06-16 19:15:32 +0000
commit67a924be4a087f0219dfa053d23a5fd12e52e481 (patch)
treee2c11d2442b6cc77a4c7f7634109e60cbf0dbe03 /CMakeLists.txt
parentb1665532799a84f5238b494a74f863bf6115fef1 (diff)
The visibility warning is only valid on non-msvc platforms
Change-Id: Iec90ac8654d08b63cfda7d14c370f3c800c74038 Reviewed-on: https://code.wireshark.org/review/2263 Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3e879a44a..456bdbafba 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -392,8 +392,10 @@ check_c_compiler_flag(-fvisibility=hidden FVHIDDEN)
if(FVHIDDEN)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -fvisibility=hidden")
else() # TODO add alternate compiler flags for hiding symbols
- message(WARNING "Hiding shared library symbols is not supported by the compiler."
- " All shared library symbols will be exported.")
+ if( NOT CMAKE_C_COMPILER_ID MATCHES "MSVC")
+ message(WARNING "Hiding shared library symbols is not supported by the compiler."
+ " All shared library symbols will be exported.")
+ endif()
endif()
if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")