aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2014-11-18 15:59:44 +0000
committerGraham Bloice <graham.bloice@trihedral.com>2014-11-19 11:19:31 +0000
commit61b0638e945b4b91dcd21d6f6fbd810281d9408a (patch)
tree19dbae4a43bec6fa8b418b9ce65f0bba44a53a18 /CMakeLists.txt
parent39b0c2def0bc94b47055650351c830822aabcadc (diff)
Remove Windows linker flags from the CMake link flags test as the
test doesn't actually pass the flags to the VS linker. Change-Id: I5d546afcb80a49e39143078bc8f0855b0ba0f7e8 Reviewed-on: https://code.wireshark.org/review/5384 Petri-Dish: Graham Bloice <graham.bloice@trihedral.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 00151ca981..ccd0d9f416 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -195,6 +195,10 @@ if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
${LOCAL_CFLAGS}
${WARNINGS_CFLAGS}
)
+
+ # Set in Makefile.nmake
+ set(WS_LINK_FLAGS "/LARGEADDRESSAWARE /MANIFEST:NO")
+
else()
if(CMAKE_OSX_DEPLOYMENT_TARGET)
if(APPLE)
@@ -432,13 +436,7 @@ else()
endif()
-if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
- # Set in Makefile.nmake
- set(WIRESHARK_LD_FLAGS
- /LARGEADDRESSAWARE
- /MANIFEST:NO
- )
-else()
+if(NOT CMAKE_C_COMPILER_ID MATCHES "MSVC")
set(WIRESHARK_LD_FLAGS
-Wl,--as-needed
# -flto