aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Mayer <jmayer@loplof.de>2014-11-05 21:10:07 +0100
committerJörg Mayer <jmayer@loplof.de>2014-11-05 20:13:08 +0000
commit55fb7ea0e3bd2fec8d00418444bb717f507b32ca (patch)
tree837b43159f67b9ae050830715a8cfe0b1aef3dca /CMakeLists.txt
parent80b36cdbde90ac9639938a14e8fd90a79602666a (diff)
Enable some runtime sanity checks when using at least gcc 4.9
Change-Id: I33208d4c27a27fb9222577ca176357035eeb7ba1 Reviewed-on: https://code.wireshark.org/review/5150 Reviewed-by: Jörg Mayer <jmayer@loplof.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f10ca2adb..175e278415 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -234,6 +234,11 @@ else()
-fwrapv
-fno-strict-overflow
-fno-delete-null-pointer-checks
+ -fsanitize=undefined # compile and runtime checks
+ # -fsanitize=float-divide-by-zero
+ # -fsanitize=float-cast-overflow
+ # -fsanitize=address
+ # -fno-sanitize-recover # Abort during runtime
-Wvla
-Waddress
-Wattributes