aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis La Goutte <alexis.lagoutte@gmail.com>2016-02-01 21:33:33 +0100
committerAlexis La Goutte <alexis.lagoutte@gmail.com>2016-03-07 07:57:29 +0000
commit4f3a88989ed6794134cc94ad678dce730f2fd1e3 (patch)
tree0eea094dc5d9601c83f44f325ea0a0b5c940b3fc /CMakeLists.txt
parent6ea3f3790ac853151d8179a62561593197a864dd (diff)
Add conflict check filter
Set ENABLE_CHECK_FILTER to 1 for get list of display filter with conflict... Ping-Bug:2402 Change-Id: I8d56b1573120d1a29d437aae1088be242e15e9a3 Reviewed-on: https://code.wireshark.org/review/13644 Petri-Dish: Alexis La Goutte <alexis.lagoutte@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Michael Mann <mmann78@netscape.net> Reviewed-by: Alexis La Goutte <alexis.lagoutte@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a62cbda39..571cf43fcc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -989,6 +989,10 @@ elseif(QT_FOUND)
endif()
endif()
+if(ENABLE_CHECKHF_CONFLICT)
+ set(ENABLE_CHECK_FILTER 1)
+endif()
+
message(STATUS "C-Flags: ${CMAKE_C_FLAGS}")
message(STATUS "CXX-Flags: ${CMAKE_CXX_FLAGS}")
message(STATUS "Warnings as errors: ${WERROR_COMMON_FLAGS}")