aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGraham Bloice <graham.bloice@trihedral.com>2014-06-25 00:05:08 +0100
committerGraham Bloice <graham.bloice@trihedral.com>2014-06-26 21:34:38 +0000
commit4742fc8ed25f64822c711610e847298600319282 (patch)
treeedb2b6604a07de89319de2fa4ea9dc8e132d3ac3 /CMakeLists.txt
parentc9b03b424f708b6f89bd9b95e8c1e28f9626c39d (diff)
Fixed linker flags for MSVC to not attempt to make and link a manifest
Added solution "folder" for tests. Change-Id: I96dfb4a28fb7aaf3e84cea026e1f5d15afe6c0c6 Reviewed-on: https://code.wireshark.org/review/2635 Tested-by: Graham Bloice <graham.bloice@trihedral.com> Reviewed-by: Evan Huus <eapache@gmail.com> Reviewed-by: Graham Bloice <graham.bloice@trihedral.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0c0ef4c8c8..69aaa2c524 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -398,7 +398,7 @@ endif()
if( CMAKE_C_COMPILER_ID MATCHES "MSVC")
# Set in Makefile.nmake
set(WIRESHARK_LD_FLAGS
- /LARGEADDRESSAWARE
+ "/LARGEADDRESSAWARE /MANIFEST:NO"
)
else()
set(WIRESHARK_LD_FLAGS
@@ -1185,7 +1185,7 @@ if(BUILD_dftest)
)
add_executable(dftest ${dftest_FILES})
set_target_properties(dftest PROPERTIES LINK_FLAGS "${WS_LINK_FLAGS}")
- set_target_properties(dftest PROPERTIES FOLDER "Executables")
+ set_target_properties(dftest PROPERTIES FOLDER "Tests")
target_link_libraries(dftest ${dftest_LIBS})
install(TARGETS dftest RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
endif()