aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEvan Huus <eapache@gmail.com>2014-08-04 07:22:59 -0400
committerEvan Huus <eapache@gmail.com>2014-08-04 14:31:37 +0000
commit37b5b095b90ea714478049408084f39707882a06 (patch)
tree626067a89976a18ce078c093a3609aa1de25e173 /CMakeLists.txt
parent76e4698b6d5bf1c8a2aac419093d5cd52508a003 (diff)
Rip out the filetap code
We decided at sharkfest that this wasn't the right design for file dissection; we have more-or-less settled on way forward, but nobody's shown interest in implementing it. Whether or not that ever happens, this code is effectively dead and should be removed. Change-Id: I14d6086df3204fffb6485228db39d9f407661417 Reviewed-on: https://code.wireshark.org/review/3400 Petri-Dish: Evan Huus <eapache@gmail.com> Tested-by: Petri Dish Buildbot <buildbot-no-reply@wireshark.org> Reviewed-by: Evan Huus <eapache@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2163db3692..813f2ee4b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -121,7 +121,6 @@ include_directories(
${CMAKE_BINARY_DIR}
${CMAKE_SOURCE_DIR}
${CMAKE_SOURCE_DIR}/epan
- ${CMAKE_SOURCE_DIR}/filetap
${CMAKE_SOURCE_DIR}/tools/lemon
${CMAKE_SOURCE_DIR}/wiretap
)
@@ -794,14 +793,13 @@ add_subdirectory( capchild )
add_subdirectory( caputils )
add_subdirectory( codecs )
add_subdirectory( epan )
-add_subdirectory( filetap )
add_subdirectory( tools/lemon )
add_subdirectory( ui )
add_subdirectory( wiretap )
add_subdirectory( wsutil )
if(NOT WIN32)
- add_custom_target(dumpabi DEPENDS dumpabi-libwireshark dumpabi-libfiletap dumpabi-libwiretap dumpabi-libwsutil color.h)
+ add_custom_target(dumpabi DEPENDS dumpabi-libwireshark dumpabi-libwiretap dumpabi-libwsutil color.h)
endif()
if(ENABLE_ECHLD)
@@ -881,7 +879,6 @@ set( IN_FILES
image/editcap.rc.in
image/captype.rc.in
image/libwsutil.rc.in
- image/filetap.rc.in
image/wiretap.rc.in
packaging/macosx/Info.plist.in
plugins/ethercat/plugin.rc.in
@@ -923,7 +920,6 @@ link_directories(
${CMAKE_BINARY_DIR}/caputils
${CMAKE_BINARY_DIR}/codecs
${CMAKE_BINARY_DIR}/epan
- ${CMAKE_BINARY_DIR}/filetap
${CMAKE_BINARY_DIR}/wiretap
${CMAKE_BINARY_DIR}/wsutil
)
@@ -1147,7 +1143,6 @@ endif()
if(BUILD_tfshark)
set(tfshark_LIBS
- filetap
ui
${LIBEPAN_LIBS}
${APPLE_CORE_FOUNDATION_LIBRARY}