aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2011-07-13 00:08:02 +0200
committerHolger Hans Peter Freyther <zecke@selfish.org>2011-07-13 00:10:02 +0200
commit0729969530ddfc4c5dee54bc4647aafb73521cd6 (patch)
tree0db4aa93273ad3cc9bad34904f472bc993b3ff12
parent666f9db529bf424701f88eed505d6e692790bb98 (diff)
manual: Start with a skeleton of a usermanual
This is a DocBook skeleton that should morph into a proper usermanual for the SIMtrace.
-rw-r--r--docs/.gitignore4
-rw-r--r--docs/Makefile42
-rw-r--r--docs/README9
-rw-r--r--docs/chapters/appendix.xml9
-rw-r--r--docs/chapters/building.xml8
-rw-r--r--docs/chapters/introduction.xml8
-rw-r--r--docs/chapters/using.xml20
-rw-r--r--docs/usermanual.xml46
8 files changed, 146 insertions, 0 deletions
diff --git a/docs/.gitignore b/docs/.gitignore
new file mode 100644
index 0000000..494f28a
--- /dev/null
+++ b/docs/.gitignore
@@ -0,0 +1,4 @@
+*.texi
+usermanual.txt
+usermanual.pdf
+*.sw?
diff --git a/docs/Makefile b/docs/Makefile
new file mode 100644
index 0000000..c208358
--- /dev/null
+++ b/docs/Makefile
@@ -0,0 +1,42 @@
+# XSL stylesheets downloaded from http://docbook.sourceforge.net/release/xsl/current/html/
+# Makefile from BitBake/OpenEmbedded manuals
+
+topdir = .
+manual = $(topdir)/usermanual.xml
+# types = pdf txt rtf ps xhtml html man tex texi dvi
+# types = pdf txt
+types = $(docbooktotypes)
+docbooktotypes = pdf txt
+# htmlcssfile =
+# htmlcss =
+cleanfiles = $(foreach i,$(types),$(topdir)/$(i))
+
+ifdef DEBUG
+define command
+ $(1)
+endef
+else
+define command
+ @echo $(2) $(3) $(4)
+ @$(1)
+endef
+endif
+
+all: $(types)
+
+lint: $(manual) FORCE
+ $(call command,xmllint --xinclude --postvalid --noout $(manual),XMLLINT $(manual))
+
+$(types): lint FORCE
+
+
+$(docbooktotypes): $(manual)
+ $(call command,docbook2$@ $(manual),DOCBOOK2 $@ $(manual))
+
+clean:
+ rm -rf $(cleanfiles)
+
+$(foreach i,$(types) $(foreach type,$(htmltypes),$(type)-nochunks),clean-$(i)):
+ rm -rf $(patsubst clean-%,%,$@)
+
+FORCE:
diff --git a/docs/README b/docs/README
new file mode 100644
index 0000000..0a70c26
--- /dev/null
+++ b/docs/README
@@ -0,0 +1,9 @@
+This should be our user manual, it is created using docbook and
+can be compiled by either. Patches for additional sections are
+more than welcome.
+
+$ make
+
+or
+
+$ dblatex usermanual.tex
diff --git a/docs/chapters/appendix.xml b/docs/chapters/appendix.xml
new file mode 100644
index 0000000..2f684a3
--- /dev/null
+++ b/docs/chapters/appendix.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+<appendix id="appendix_sql_v09">
+ <title>SQL Tabellen v0.9</title>
+ <programlisting>
+ <inlinemediaobject><imageobject><imagedata format="linespecific" fileref="file" /></imageobject></inlinemediaobject>
+ </programlisting>
+</appendix>
+-->
diff --git a/docs/chapters/building.xml b/docs/chapters/building.xml
new file mode 100644
index 0000000..7c4c9ac
--- /dev/null
+++ b/docs/chapters/building.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<chapter id="chapter_building">
+ <title>Getting and Building the Software</title>
+ <section id="building_dependencies">
+ <title>Installing Dependencies</title>
+ <para></para>
+ </section>
+</chapter>
diff --git a/docs/chapters/introduction.xml b/docs/chapters/introduction.xml
new file mode 100644
index 0000000..885d7c4
--- /dev/null
+++ b/docs/chapters/introduction.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<chapter id="chapter_introduction">
+ <title>Introduction</title>
+ <section id="intro_overview">
+ <title>Overview</title>
+ <para></para>
+ </section>
+</chapter>
diff --git a/docs/chapters/using.xml b/docs/chapters/using.xml
new file mode 100644
index 0000000..f0afd30
--- /dev/null
+++ b/docs/chapters/using.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<chapter id="chapter_using">
+ <title>Sniffing your SIM</title>
+
+ <section id="launching_simtrace">
+ <title>Launching SIMtrace</title>
+ <para></para>
+ <screen>
+$ <command>simtrace</command>
+ </screen>
+ </section>
+
+ <section id="launching_wireshark">
+ <title>Launching Wireshark</title>
+ <para></para>
+ <screen>
+$ <command>wireshark</command>
+ </screen>
+ </section>
+</chapter>
diff --git a/docs/usermanual.xml b/docs/usermanual.xml
new file mode 100644
index 0000000..8ff39ad
--- /dev/null
+++ b/docs/usermanual.xml
@@ -0,0 +1,46 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!--
+ ex:ts=4:sw=4:sts=4:et
+ -*- tab-width: 4; c-basic-offset: 4; indent-tabs-mode: nil -*-
+-->
+<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.2//EN"
+"http://www.oasis-open.org/docbook/xml/4.2/docbookx.dtd" [
+<!ENTITY chapter-introduction SYSTEM "chapters/introduction.xml">
+<!ENTITY chapter-using SYSTEM "chapters/using.xml">
+<!ENTITY chapter-building SYSTEM "chapters/building.xml">
+<!ENTITY chapter-appendix SYSTEM "chapters/appendix.xml">
+]>
+
+<book>
+ <bookinfo>
+ <revhistory>
+ <revision>
+ <revnumber>0.0.1</revnumber>
+ <date>12 July 2011</date>
+ <authorinitials>z</authorinitials>
+ <revremark>Initial</revremark>
+ </revision>
+ </revhistory>
+
+ <title>SIMtrace Usermanual</title>
+
+ <copyright>
+ <year>2011</year>
+ </copyright>
+
+ <legalnotice>
+ <para>This work is licensed under a Creative Commons Attribution 3.0
+ Unported License. To view a copy of this license, visit <ulink
+ url="http://creativecommons.org/licenses/by-sa/3.0/">http://creativecommons.org/licenses/by-sa/3.0/</ulink>
+ or send a letter to Creative Commons, 559 Nathan Abbott Way, Stanford,
+ California 94305, USA.</para>
+ </legalnotice>
+ </bookinfo>
+
+ <!-- Main chapters-->
+ &chapter-introduction;
+ &chapter-using;
+ &chapter-building;
+
+ &chapter-appendix;
+</book>