aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKyle Keen <keenerd@gmail.com>2012-10-24 17:31:22 +0200
committerSteve Markgraf <steve@steve-m.de>2012-10-24 17:35:30 +0200
commit995a195f4d41e343781a4da267b960a6d6eab670 (patch)
treead164a1d49dc6b2c3e4e66b660182638df3d75a1 /configure.ac
parented449bc04d534c523334cafb6e8ce6ee6424bb3d (diff)
rtl_test: add ppm measurement
Use with caution, the result highly depends on the accuracy of the clocksource your machine uses. On some machines it may be quite accurate, on others completely off. Signed-off-by: Steve Markgraf <steve@steve-m.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7bc8e1d..1b94701 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,6 +39,9 @@ AC_CHECK_LIB(pthread, pthread_create, [LIBS="$LIBS -lpthread"])
dnl libmath (for rtl_fm)
AC_CHECK_LIB(m, atan2, [LIBS="$LIBS -lm"])
+dnl librealtime (for rtl_test)
+AC_CHECK_LIB(rt, clock_gettime, [LIBS="$LIBS"])
+
# The following test is taken from WebKit's webkit.m4
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -fvisibility=hidden "