aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDimitri Stolnikov <horiz0n@gmx.net>2012-05-25 22:55:54 +0200
committerDimitri Stolnikov <horiz0n@gmx.net>2012-05-25 22:55:54 +0200
commit932d6a6fb2e574d395484206f3bcfaf542981ec5 (patch)
tree428292a5166b56f35c130b2a344da31a3b721ea8 /configure.ac
parentf3a63028665894c4934ed52c6177db961f5164d3 (diff)
autotools: check for pthread library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3af474a..3703c37 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,11 @@ AC_CONFIG_MACRO_DIR([m4])
dnl checks for header files
AC_HEADER_STDC
AC_CHECK_HEADERS(sys/types.h)
+AC_CHECK_HEADERS(pthread.h,, [AC_MSG_ERROR([pthread.h required])])
+
+dnl checks for required libraries
+dnl pthreads
+AC_CHECK_LIB(pthread, pthread_create, [LIBS="$LIBS -lpthread"])
# The following test is taken from WebKit's webkit.m4
saved_CFLAGS="$CFLAGS"