summaryrefslogtreecommitdiffstats
path: root/src/shared/libosmocore/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'src/shared/libosmocore/configure.in')
-rw-r--r--src/shared/libosmocore/configure.in66
1 files changed, 0 insertions, 66 deletions
diff --git a/src/shared/libosmocore/configure.in b/src/shared/libosmocore/configure.in
deleted file mode 100644
index b5eea6b1..00000000
--- a/src/shared/libosmocore/configure.in
+++ /dev/null
@@ -1,66 +0,0 @@
-AC_INIT([libosmocore],
- m4_esyscmd([./git-version-gen .tarball-version]),
- [openbsc-devel@lists.openbsc.org])
-
-AM_INIT_AUTOMAKE([dist-bzip2])
-
-dnl kernel style compile messages
-m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
-
-dnl checks for programs
-AC_PROG_MAKE_SET
-AC_PROG_CC
-AC_PROG_INSTALL
-LT_INIT
-AC_PROG_LIBTOOL
-
-AC_CONFIG_MACRO_DIR([m4])
-
-dnl checks for header files
-AC_HEADER_STDC
-AC_CHECK_HEADERS(execinfo.h sys/select.h)
-
-# The following test is taken from WebKit's webkit.m4
-saved_CFLAGS="$CFLAGS"
-CFLAGS="$CFLAGS -fvisibility=hidden "
-AC_MSG_CHECKING([if ${CC} supports -fvisibility=hidden])
-AC_COMPILE_IFELSE([char foo;],
- [ AC_MSG_RESULT([yes])
- SYMBOL_VISIBILITY="-fvisibility=hidden"],
- AC_MSG_RESULT([no]))
-CFLAGS="$saved_CFLAGS"
-AC_SUBST(SYMBOL_VISIBILITY)
-
-dnl Generate the output
-AM_CONFIG_HEADER(config.h)
-
-AC_ARG_ENABLE(talloc,
- [ --disable-talloc Disable building talloc memory allocator ],
- [enable_talloc=0], [enable_talloc=1])
-AM_CONDITIONAL(ENABLE_TALLOC, test "x$enable_talloc" = "x1")
-
-AC_ARG_ENABLE(tests,
- [ --disable-tests Disable building test programs ],
- [enable_tests=0], [enable_tests=1])
-AM_CONDITIONAL(ENABLE_TESTS, test "x$enable_tests" = "x1")
-
-AC_ARG_ENABLE(vty,
- [ --disable-vty Disable building VTY telnet interface ],
- [enable_vty=0], [enable_vty=1])
-AM_CONDITIONAL(ENABLE_VTY, test "x$enable_vty" = "x1")
-
-
-AC_OUTPUT(
- libosmocore.pc
- libosmovty.pc
- include/osmocom/Makefile
- include/osmocom/vty/Makefile
- include/osmocore/Makefile
- include/osmocore/protocol/Makefile
- include/Makefile
- src/Makefile
- src/vty/Makefile
- tests/Makefile
- tests/timer/Makefile
- tests/sms/Makefile
- Makefile)