summaryrefslogtreecommitdiffstats
path: root/src/shared/libosmocore/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/shared/libosmocore/configure.ac')
-rw-r--r--src/shared/libosmocore/configure.ac71
1 files changed, 57 insertions, 14 deletions
diff --git a/src/shared/libosmocore/configure.ac b/src/shared/libosmocore/configure.ac
index b923a218..52ab850f 100644
--- a/src/shared/libosmocore/configure.ac
+++ b/src/shared/libosmocore/configure.ac
@@ -20,6 +20,9 @@ dnl checks for header files
AC_HEADER_STDC
AC_CHECK_HEADERS(execinfo.h sys/select.h sys/socket.h syslog.h ctype.h)
+AC_PATH_PROG(DOXYGEN,doxygen,false)
+AM_CONDITIONAL(HAVE_DOXYGEN, test $DOXYGEN != false)
+
# The following test is taken from WebKit's webkit.m4
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS -fvisibility=hidden "
@@ -39,40 +42,40 @@ AC_ARG_ENABLE(talloc,
[--disable-talloc],
[Disable building talloc memory allocator]
)],
- [enable_talloc=0], [enable_talloc=1])
-AM_CONDITIONAL(ENABLE_TALLOC, test "x$enable_talloc" = "x1")
+ [enable_talloc=$enableval], [enable_talloc="yes"])
+AM_CONDITIONAL(ENABLE_TALLOC, [test x"$enable_talloc" = x"yes"])
AC_ARG_ENABLE(plugin,
[AS_HELP_STRING(
[--disable-plugin],
[Disable support for dlopen plugins],
)],
- [enable_plugin=0], [enable_plugin=1])
-AM_CONDITIONAL(ENABLE_PLUGIN, test "x$enable_plugin" = "x1")
+ [enable_plugin=$enableval], [enable_plugin="yes"])
+AM_CONDITIONAL(ENABLE_PLUGIN, test x"$enable_plugin" = x"yes")
AC_ARG_ENABLE(tests,
[AS_HELP_STRING(
[--disable-tests],
[Disable building test programs]
)],
- [enable_tests=0], [enable_tests=1])
-AM_CONDITIONAL(ENABLE_TESTS, test "x$enable_tests" = "x1")
+ [enable_tests=$enableval], [enable_tests="yes"])
+AM_CONDITIONAL(ENABLE_TESTS, test x"$enable_tests" = x"yes")
AC_ARG_ENABLE(vty,
[AS_HELP_STRING(
[--disable-vty],
[Disable building VTY telnet interface]
)],
- [enable_vty=0], [enable_vty=1])
-AM_CONDITIONAL(ENABLE_VTY, test "x$enable_vty" = "x1")
+ [enable_vty=$enableval], [enable_vty="yes"])
+AM_CONDITIONAL(ENABLE_VTY, test x"$enable_vty" = x"yes")
AC_ARG_ENABLE(panic_infloop,
[AS_HELP_STRING(
[--enable-panic-infloop],
[Trigger infinite loop on panic rather than fprintf/abort]
)],
- [panic_infloop=1], [panic_infloop=0])
-if test "x$panic_infloop" = "x1"
+ [panic_infloop=$enableval], [panic_infloop="no"])
+if test x"$panic_infloop" = x"yes"
then
AC_DEFINE([PANIC_INFLOOP],[1],[Use infinite loop on panic rather than fprintf/abort])
fi
@@ -82,8 +85,8 @@ AC_ARG_ENABLE(bsc_fd_check,
[--enable-bsc-fd-check],
[Instrument bsc_register_fd to check that the fd is registered]
)],
- [fd_check=1], [fd_check=0])
-if test "x$fd_check" = "x1"
+ [fd_check=$enableval], [fd_check="no"])
+if test x"$fd_check" = x"no"
then
AC_DEFINE([BSC_FD_CHECK],[1],[Instrument the bsc_register_fd])
fi
@@ -93,9 +96,43 @@ AC_ARG_ENABLE(msgfile,
[--disable-msgfile],
[Disable support for the msgfile],
)],
- [enable_msgfile=0], [enable_msgfile=1])
-AM_CONDITIONAL(ENABLE_MSGFILE, test "x$enable_msgfile" = "x1")
+ [enable_msgfile=$enableval], [enable_msgfile="yes"])
+AM_CONDITIONAL(ENABLE_MSGFILE, test x"$enable_msgfile" = x"yes")
+AC_ARG_ENABLE(serial,
+ [AS_HELP_STRING(
+ [--disable-serial],
+ [Disable support for the serial helpers],
+ )],
+ [enable_serial=$enableval], [enable_serial="yes"])
+AM_CONDITIONAL(ENABLE_SERIAL, test x"$enable_serial" = x"yes")
+
+AC_ARG_ENABLE(utilities,
+ [AS_HELP_STRING(
+ [--disable-utilities],
+ [Disable building utility programs],
+ )],
+ [enable_utilities=$enableval], [enable_utilities="yes"])
+AM_CONDITIONAL(ENABLE_UTILITIES, test x"$enable_utilities" = x"yes")
+
+AC_ARG_ENABLE(embedded,
+ [AS_HELP_STRING(
+ [--enable-embedded],
+ [Enable building for embedded use and disable unsupported features]
+ )],
+ [embedded=$enableval], [embedded="no"])
+if test x"$embedded" = x"yes"
+then
+ AC_DEFINE([EMBEDDED],[1],[Select building for embedded use])
+ AM_CONDITIONAL(ENABLE_TESTS, false)
+ AM_CONDITIONAL(ENABLE_PLUGIN, false)
+ AM_CONDITIONAL(ENABLE_MSGFILE, false)
+ AM_CONDITIONAL(ENABLE_SERIAL, false)
+ AM_CONDITIONAL(ENABLE_VTY, false)
+ AM_CONDITIONAL(ENABLE_TALLOC, false)
+ AM_CONDITIONAL(ENABLE_UTILITIES, false)
+ AC_DEFINE([PANIC_INFLOOP],[1],[Use infinite loop on panic rather than fprintf/abort])
+fi
AC_OUTPUT(
libosmocore.pc
@@ -120,4 +157,10 @@ AC_OUTPUT(
tests/msgfile/Makefile
tests/ussd/Makefile
tests/smscb/Makefile
+ tests/bits/Makefile
+ utils/Makefile
+ Doxyfile.core
+ Doxyfile.gsm
+ Doxyfile.vty
+ Doxyfile.codec
Makefile)