summaryrefslogtreecommitdiffstats
path: root/src/host/trxcon/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/host/trxcon/configure.ac')
-rw-r--r--src/host/trxcon/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/host/trxcon/configure.ac b/src/host/trxcon/configure.ac
index a94859b7..1f24260d 100644
--- a/src/host/trxcon/configure.ac
+++ b/src/host/trxcon/configure.ac
@@ -18,6 +18,17 @@ PKG_CHECK_MODULES(LIBOSMOGSM, libosmogsm)
dnl checks for header files
AC_HEADER_STDC
+AC_ARG_ENABLE(sanitize,
+ [AS_HELP_STRING(
+ [--enable-sanitize],
+ [Compile with address sanitizer enabled],
+ )], [sanitize=$enableval], [sanitize="no"])
+if test x"$sanitize" = x"yes"
+then
+ CFLAGS="$CFLAGS -fsanitize=address -fsanitize=undefined"
+ CPPFLAGS="$CPPFLAGS -fsanitize=address -fsanitize=undefined"
+fi
+
dnl Checks for typedefs, structures and compiler characteristics
AC_OUTPUT(