summaryrefslogtreecommitdiffstats
path: root/src/host/layer23/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/host/layer23/configure.ac')
-rw-r--r--src/host/layer23/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/host/layer23/configure.ac b/src/host/layer23/configure.ac
index 9335e66e..1ff1bb70 100644
--- a/src/host/layer23/configure.ac
+++ b/src/host/layer23/configure.ac
@@ -21,6 +21,13 @@ AC_CHECK_LIB(gps, gps_waiting, LIBGPS_CFLAGS=" -D_HAVE_GPSD" LIBGPS_LIBS=" -lgps
AC_SUBST([LIBGPS_CFLAGS])
AC_SUBST([LIBGPS_LIBS])
+dnl Optional transceiver
+AC_ARG_ENABLE([transceiver], [AS_HELP_STRING([--enable-transceiver], [Build the transceiver application])],
+ [osmo_ac_build_transceiver="$enableval"])
+if test "$osmo_ac_build_transceiver" = "yes" ; then
+ PKG_CHECK_MODULES(LIBOSMODSP, libosmodsp)
+fi
+AM_CONDITIONAL(BUILD_TRANSCEIVER, test "x$osmo_ac_build_transceiver" = "xyes")
dnl checks for header files
AC_HEADER_STDC
@@ -32,6 +39,7 @@ AC_OUTPUT(
src/common/Makefile
src/misc/Makefile
src/mobile/Makefile
+ src/transceiver/Makefile
include/Makefile
include/osmocom/Makefile
include/osmocom/bb/Makefile