summaryrefslogtreecommitdiffstats
path: root/src/host/layer2/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/host/layer2/src/Makefile.am')
-rw-r--r--src/host/layer2/src/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/host/layer2/src/Makefile.am b/src/host/layer2/src/Makefile.am
new file mode 100644
index 00000000..5cca4afa
--- /dev/null
+++ b/src/host/layer2/src/Makefile.am
@@ -0,0 +1,10 @@
+INCLUDES = $(all_includes) -I$(top_srcdir)/include
+AM_CFLAGS=-Wall
+
+noinst_LIBRARIES = libosmocom.a
+libosmocom_a_SOURCES = libosmocom/debug.c libosmocom/msgb.c libosmocom/select.c \
+ libosmocom/talloc.c libosmocom/timer.c
+
+sbin_PROGRAMS = layer2
+layer2_SOURCES = layer2_main.c osmocom_layer2.c
+layer2_LDADD = libosmocom.a