aboutsummaryrefslogtreecommitdiffstats
path: root/src/test/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg <jolly@eversberg.eu>2017-09-11 20:37:03 +0200
committerAndreas Eversberg <jolly@eversberg.eu>2017-09-11 20:37:03 +0200
commit5b1956fe49f958a4674f4e470fc8a63bc5576016 (patch)
tree7c79249111212434497eef31a219ea1867c34ee5 /src/test/Makefile.am
parentb6326aa473ce9327ba3eb7ba2cb66eecb2572258 (diff)
Move sms and dms code (NMT) to separate lib.a
Diffstat (limited to 'src/test/Makefile.am')
-rw-r--r--src/test/Makefile.am29
1 files changed, 13 insertions, 16 deletions
diff --git a/src/test/Makefile.am b/src/test/Makefile.am
index 6bf0121..d310415 100644
--- a/src/test/Makefile.am
+++ b/src/test/Makefile.am
@@ -1,4 +1,3 @@
-AUTOMAKE_OPTIONS = subdir-objects
AM_CPPFLAGS = -Wall -g $(all_includes)
noinst_PROGRAMS = \
@@ -21,9 +20,7 @@ test_filter_LDADD = \
$(SOAPY_LIBS) \
-lm
-test_compandor_SOURCES = \
- test_compandor.c \
- dummy.c
+test_compandor_SOURCES = dummy.x test_compandor.c
test_compandor_LDADD = \
$(COMMON_LA) \
@@ -45,13 +42,11 @@ test_emphasis_LDADD = \
$(SOAPY_LIBS) \
-lm
-test_dms_SOURCES = \
- $(top_builddir)/src/nmt/dms.c \
- test_dms.c \
- dummy.c
+test_dms_SOURCES = test_dms.c dummy.c
test_dms_LDADD = \
$(COMMON_LA) \
+ $(top_builddir)/src/nmt/libdmssms.a \
$(top_builddir)/src/common/libmobile.a \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
@@ -59,13 +54,11 @@ test_dms_LDADD = \
$(SOAPY_LIBS) \
-lm
-test_sms_SOURCES = \
- $(top_builddir)/src/nmt/sms.c \
- dummy.c \
- test_sms.c
+test_sms_SOURCES = dummy.c test_sms.c
test_sms_LDADD = \
$(COMMON_LA) \
+ $(top_builddir)/src/nmt/libdmssms.a \
$(top_builddir)/src/common/libmobile.a \
$(top_builddir)/src/common/libcommon.a \
$(ALSA_LIBS) \
@@ -84,10 +77,14 @@ test_performance_LDADD = \
$(SOAPY_LIBS) \
-lm
-test_hagelbarger_SOURCES = \
- $(top_builddir)/src/common/hagelbarger.c \
- test_hagelbarger.c
+test_hagelbarger_SOURCES = dummy.c test_hagelbarger.c
test_hagelbarger_LDADD = \
- $(COMMON_LA)
+ $(COMMON_LA) \
+ $(top_builddir)/src/common/libmobile.a \
+ $(top_builddir)/src/common/libcommon.a \
+ $(ALSA_LIBS) \
+ $(UHD_LIBS) \
+ $(SOAPY_LIBS) \
+ -lm