aboutsummaryrefslogtreecommitdiffstats
path: root/src/amps/Makefile.am
diff options
context:
space:
mode:
authorAndreas Eversberg <jolly@eversberg.eu>2016-05-01 19:51:56 +0200
committerAndreas Eversberg <jolly@eversberg.eu>2016-06-17 17:03:29 +0200
commitd2c4ca4fa91d9496f5b7a5f2dc1c6b66bb52ced8 (patch)
treedd9c2d4cbe270a3fdcbacb08f566578d3386211f /src/amps/Makefile.am
parent7d5d3da8d35ee5e34eb9b3b4fbd821b9f4b28fb5 (diff)
Implementation of Advanced Mobile Phone Service (AMPS)
Diffstat (limited to 'src/amps/Makefile.am')
-rw-r--r--src/amps/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/amps/Makefile.am b/src/amps/Makefile.am
new file mode 100644
index 0000000..46cc482
--- /dev/null
+++ b/src/amps/Makefile.am
@@ -0,0 +1,25 @@
+AM_CPPFLAGS = -Wall -g $(all_includes)
+
+bin_PROGRAMS = \
+ amps
+
+amps_SOURCES = \
+ amps.c \
+ transaction.c \
+ frame.c \
+ dsp.c \
+ sysinfo.c \
+ image.c \
+ tones.c \
+ noanswer.c \
+ outoforder.c \
+ invalidnumber.c \
+ congestion.c \
+ stations.c \
+ main.c
+amps_LDADD = \
+ $(COMMON_LA) \
+ $(top_builddir)/src/common/libcommon.a \
+ $(ALSA_LIBS) \
+ -lm
+