aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 4 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 2bfe825..848f887 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,11 +63,6 @@ AC_ARG_WITH(usrp1, [
[enable USRP1 gnuradio based transceiver])
])
-AC_ARG_WITH(uhd, [
- AS_HELP_STRING([--with-uhd],
- [enable UHD based transceiver])
-])
-
AC_ARG_WITH(singledb, [
AS_HELP_STRING([--with-singledb],
[enable single daughterboard use on USRP1])
@@ -75,24 +70,22 @@ AC_ARG_WITH(singledb, [
AS_IF([test "x$with_usrp1" = "xyes"], [
PKG_CHECK_MODULES(USRP, usrp >= 3.3)
- # Find and define supported SIMD extensions
- AX_EXT
])
-AS_IF([test "x$with_uhd" = "xyes"],[
+AS_IF([test "x$with_usrp1" != "xyes"],[
PKG_CHECK_MODULES(UHD, uhd >= 003.004.000)
AC_DEFINE(USE_UHD, 1, Define to 1 if using UHD)
- AX_EXT
])
AS_IF([test "x$with_singledb" = "xyes"], [
AC_DEFINE(SINGLEDB, 1, Define to 1 for single daughterboard)
])
-AM_CONDITIONAL(UHD, [test "x$with_uhd" = "xyes"])
+# Find and define supported SIMD extensions
+AX_EXT
+
AM_CONDITIONAL(USRP1, [test "x$with_usrp1" = "xyes"])
-# Defines LIBUSB_TRANSFER_CANCELLED, LIBUSB_TRANSFER_COMPLETED, LIBUSB_SUCCESS, LIBUSB_ERROR_*
PKG_CHECK_MODULES(LIBUSB, libusb-1.0)
dnl Output files