aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index 3c79aff..7bdc181 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -21,10 +21,17 @@
include $(top_srcdir)/Makefile.common
+#UHD wins if both are defined
if UHD
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(UHD_CFLAGS)
else
+if USRP1
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(USRP_CFLAGS)
+else
+#we should never be here, as this doesn't build if one of the above
+#doesn't exist
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES)
+endif
endif
AM_CXXFLAGS = -ldl -lpthread
@@ -93,16 +100,21 @@ sigProcLibTest_LDADD = \
$(GSM_LA) \
$(COMMON_LA) $(SQLITE_LA)
+#uhd wins
if UHD
libtransceiver_la_SOURCES += UHDDevice.cpp
transceiver_LDADD += $(UHD_LIBS)
USRPping_LDADD += $(UHD_LIBS)
sigProcLibTest_LDADD += $(UHD_LIBS)
else
+if USRP1
libtransceiver_la_SOURCES += USRPDevice.cpp
transceiver_LDADD += $(USRP_LIBS)
USRPping_LDADD += $(USRP_LIBS)
sigProcLibTest_LDADD += $(USRP_LIBS)
+else
+#we should never be here, as one of the above mustbe defined for us to build
+endif
endif