aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index c2ab9ca..c8b20cd 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -69,7 +69,7 @@ libtransceiver_la_SOURCES = \
radioInterfaceResamp.cpp \
radioInterfaceMulti.cpp
-bin_PROGRAMS = osmo-trx
+bin_PROGRAMS = osmo-trx osmo-siggen
noinst_HEADERS = \
Complex.h \
@@ -99,10 +99,18 @@ osmo_trx_LDADD = \
$(GSM_LA) \
$(COMMON_LA) $(SQLITE3_LIBS)
+osmo_siggen_SOURCES = osmo-siggen.cpp
+osmo_siggen_LDADD = \
+ libtransceiver.la \
+ $(ARCH_LA) \
+ $(GSM_LA) \
+ $(COMMON_LA) $(SQLITE3_LIBS)
+
if USRP1
libtransceiver_la_SOURCES += USRPDevice.cpp
osmo_trx_LDADD += $(USRP_LIBS)
else
libtransceiver_la_SOURCES += UHDDevice.cpp
osmo_trx_LDADD += $(UHD_LIBS) $(FFTWF_LIBS)
+osmo_siggen_LDADD += $(UHD_LIBS) $(FFTWF_LIBS)
endif