aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorIvan Kluchnikov <kluchnikovi@gmail.com>2014-03-09 14:58:40 +0400
committerAlexander Chemeris <Alexander.Chemeris@gmail.com>2015-09-10 19:57:03 -0400
commit31862c5e4cb6e035cebe3ebbc3cf3452921e451e (patch)
tree7f493d406ae899c1a2ba54c511620d97a60eb8ff /debian/rules
parentf147b174475171cdf79ccba25a5e66fec282efcd (diff)
debian: Add debian directory to ease building packages
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..71e069c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,11 @@
+#!/usr/bin/make -f
+
+export DEB_BUILD_HARDENING=1
+
+
+%:
+ dh $@ --with autoreconf
+
+# ugly hack to workaround broken library paths in uhd packages
+override_dh_shlibdeps:
+ dh_shlibdeps -- --ignore-missing-info