aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Tsou <tom@tsou.cc>2013-10-11 14:55:31 -0400
committerThomas Tsou <tom@tsou.cc>2013-10-18 13:10:17 -0400
commitc064124429890393ee9a447990bc861840d73803 (patch)
treeb5ac147e2b743ff0959a0e8948940e5e45e2d31c /configure.ac
parent69d14c9a14c1e9f9ae558e5843ef23195f56f04b (diff)
Transceiver52M: Remove support for ancient libusrp versions
Current functionality with these old versions is questionable. There is no reason to use any version of GNU Radio / libusrp older than 3.3. Version 3.4.2 is the only recommended version for USRP1 users. Non-USRP1 users must use UHD driver from Ettus Research. Signed-off-by: Thomas Tsou <tom@tsou.cc>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 6ab694d..1fc58ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,18 +79,7 @@ AC_ARG_WITH(extref, [
])
AS_IF([test "x$with_usrp1" = "xyes"], [
- # Defines USRP_CFLAGS, USRP_INCLUDEDIR, and USRP_LIBS
- PKG_CHECK_MODULES(USRP, usrp > 3.1)
- # Check whether we have libusrp >= 3.2
- PKG_CHECK_EXISTS(usrp >= 3.2, libusrp_3_2=yes, libusrp_3_2=no)
- if test "x$libusrp_3_2" = "xyes";then
- AC_DEFINE(HAVE_LIBUSRP_3_2, 1, Define to 1 if you have libusrp >= 3.2)
- fi
- # Check whether we have libusrp >= 3.3
- PKG_CHECK_EXISTS(usrp >= 3.3, libusrp_3_3=yes, libusrp_3_3=no)
- if test "x$libusrp_3_3" = "xyes";then
- AC_DEFINE(HAVE_LIBUSRP_3_3, 1, Define to 1 if you have libusrp >= 3.3)
- fi
+ PKG_CHECK_MODULES(USRP, usrp >= 3.3)
# Find and define supported SIMD extensions
AX_EXT
])