aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Tsou <tom@tsou.cc>2013-10-16 00:31:18 -0400
committerThomas Tsou <tom@tsou.cc>2013-10-18 13:10:18 -0400
commit010fff783bf658e79b0b32ad64a44af4e3f22b1e (patch)
treec20d18d41b36261f9e525bdfb5bea7e1a24c66a5 /configure.ac
parent61b4a6ad9f959421b2bf61e6e55bb0713f0db822 (diff)
Transceiver52M: Move reference select from compile time to database
Enabling the external reference on UHD devices through the configure time switch is awkward. Use a database variable "TRX.Reference" with '0' or '1' value for internal and external references respectively. Use internal reference is no entry is defined. Signed-off-by: Thomas Tsou <tom@tsou.cc>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 1fc58ea..42fcde6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,11 +73,6 @@ AC_ARG_WITH(singledb, [
[enable single daughterboard use on USRP1])
])
-AC_ARG_WITH(extref, [
- AS_HELP_STRING([--with-extref],
- [enable external reference on UHD devices])
-])
-
AS_IF([test "x$with_usrp1" = "xyes"], [
PKG_CHECK_MODULES(USRP, usrp >= 3.3)
# Find and define supported SIMD extensions
@@ -90,10 +85,6 @@ AS_IF([test "x$with_uhd" = "xyes"],[
AX_EXT
])
-AS_IF([test "x$with_extref" = "xyes"], [
- AC_DEFINE(EXTREF, 1, Define to 1 for external reference)
-])
-
AS_IF([test "x$with_singledb" = "xyes"], [
AC_DEFINE(SINGLEDB, 1, Define to 1 for single daughterboard)
])