aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
authorTom Tsou <tom.tsou@ettus.com>2016-06-22 16:16:30 -0700
committerTom Tsou <tom.tsou@ettus.com>2016-07-01 03:07:27 -0700
commit35222296fef378977a83a4ee89d8c3ef9bc62a3f (patch)
treec5551e02f5e9f30e970de1fabdbefeb3bc4842aa /Transceiver52M/Makefile.am
parent28670fb5dad8e48ff74051a5bbe0c8309b04c817 (diff)
mcbts: Add multi-ARFCN channelizing filters
Introduce polyphase channelizer (Rx) and synthesis (Tx) filterbanks, which serve as the signal processing backend for multi-carrier GSM. Fast Fourier Transform (FFT) is used internally. FFTW is added as a new build dependency. Signed-off-by: Tom Tsou <tom.tsou@ettus.com>
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index ec72f8c..52ec995 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -57,7 +57,11 @@ COMMON_SOURCES = \
radioBuffer.cpp \
sigProcLib.cpp \
signalVector.cpp \
- Transceiver.cpp
+ Transceiver.cpp \
+ ChannelizerBase.cpp \
+ Channelizer.cpp \
+ Synthesis.cpp \
+ common/fft.c
libtransceiver_la_SOURCES = \
$(COMMON_SOURCES) \
@@ -79,10 +83,14 @@ noinst_HEADERS = \
Transceiver.h \
USRPDevice.h \
Resampler.h \
+ ChannelizerBase.h \
+ Channelizer.h \
+ Synthesis.h \
common/convolve.h \
common/convert.h \
common/scale.h \
- common/mult.h
+ common/mult.h \
+ common/fft.h
osmo_trx_SOURCES = osmo-trx.cpp
osmo_trx_LDADD = \
@@ -96,5 +104,5 @@ libtransceiver_la_SOURCES += USRPDevice.cpp
osmo_trx_LDADD += $(USRP_LIBS)
else
libtransceiver_la_SOURCES += UHDDevice.cpp
-osmo_trx_LDADD += $(UHD_LIBS)
+osmo_trx_LDADD += $(UHD_LIBS) $(FFTWF_LIBS)
endif