aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
authorThomas Tsou <tom@tsou.cc>2013-10-30 21:18:55 -0400
committerThomas Tsou <tom@tsou.cc>2013-11-15 23:32:35 -0500
commit7e4e536b1bfc9b20df6b30d427de29e3cc5bf5cf (patch)
tree31b73f9d77cc616c57cd9cc61ca9d608533205e9 /Transceiver52M/Makefile.am
parent204a9f135ac2408dd62b55462ebe4b2d10be4f56 (diff)
Transceiver52M: Add ARM NEON support
Similar to the existing Intel SSE cases, add support for NEON vector floating point SIMD processing. In this case, use ARM assembly directly as the NEON intrinsics do not generate preferential code output. Currently support NEON vectorized convolution and floating point integer conversions. Signed-off-by: Thomas Tsou <tom@tsou.cc>
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index c1cfb1b..981447f 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -24,9 +24,13 @@ include $(top_srcdir)/Makefile.common
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) -I./common
AM_CXXFLAGS = -ldl -lpthread
-SUBDIRS = x86
+SUBDIRS = arm x86
+if ARCH_ARM
+ARCH_LA = arm/libarch.la
+else
ARCH_LA = x86/libarch.la
+endif
if USRP1
AM_CPPFLAGS += $(USRP_CFLAGS)
@@ -72,7 +76,8 @@ noinst_HEADERS = \
USRPDevice.h \
Resampler.h \
common/convolve.h \
- common/convert.h
+ common/convert.h \
+ common/scale.h
transceiver_SOURCES = runTransceiver.cpp
transceiver_LDADD = \