aboutsummaryrefslogtreecommitdiffstats
path: root/Transceiver52M/Makefile.am
diff options
context:
space:
mode:
authorThomas Tsou <tom@tsou.cc>2013-11-15 21:14:33 -0500
committerThomas Tsou <tom@tsou.cc>2013-11-16 01:44:07 -0500
commit85b179d125bb0b969188599f57a2f5dbb9b0151d (patch)
treea489a19f64f0e28e97008ffc814b5391f7874498 /Transceiver52M/Makefile.am
parent2e622ff131e06907f26f1eb1edd603e2f8ada118 (diff)
Transceiver52M: Create new osmo-trx executable
Create new main executable with full command line option parsing of relevant parameters. Database configuration table still exists (and must exist because of the global gConfig object), but can be bypassed with command line options. Signed-off-by: Thomas Tsou <tom@tsou.cc>
Diffstat (limited to 'Transceiver52M/Makefile.am')
-rw-r--r--Transceiver52M/Makefile.am11
1 files changed, 5 insertions, 6 deletions
diff --git a/Transceiver52M/Makefile.am b/Transceiver52M/Makefile.am
index 21b6e2e..d0a20f4 100644
--- a/Transceiver52M/Makefile.am
+++ b/Transceiver52M/Makefile.am
@@ -64,8 +64,7 @@ libtransceiver_la_SOURCES = \
radioInterfaceResamp.cpp \
radioInterfaceDiversity.cpp
-noinst_PROGRAMS = \
- transceiver
+bin_PROGRAMS = osmo-trx
noinst_HEADERS = \
Complex.h \
@@ -83,8 +82,8 @@ noinst_HEADERS = \
common/scale.h \
common/mult.h
-transceiver_SOURCES = runTransceiver.cpp
-transceiver_LDADD = \
+osmo_trx_SOURCES = osmo-trx.cpp
+osmo_trx_LDADD = \
libtransceiver.la \
$(ARCH_LA) \
$(GSM_LA) \
@@ -92,8 +91,8 @@ transceiver_LDADD = \
if USRP1
libtransceiver_la_SOURCES += USRPDevice.cpp
-transceiver_LDADD += $(USRP_LIBS)
+osmo_trx_LDADD += $(USRP_LIBS)
else
libtransceiver_la_SOURCES += UHDDevice.cpp
-transceiver_LDADD += $(UHD_LIBS)
+osmo_trx_LDADD += $(UHD_LIBS)
endif