aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Chemeris <Alexander.Chemeris@gmail.com>2013-06-16 14:29:54 +0400
committerAlexander Chemeris <Alexander.Chemeris@gmail.com>2013-06-16 14:29:54 +0400
commit040b3057899ab523861f1225f629d5c8c7d5820b (patch)
tree7efcd5478959967da43ade5e3c174967900d521f /Makefile.am
parentfc40a84d9ba3d798ff51c15d6197ad49e29b3d57 (diff)
Checking in build system for the Transceiver.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..058876d
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,46 @@
+#
+# Copyright 2008 Free Software Foundation, Inc.
+#
+# This software is distributed under the terms of the GNU Public License.
+# See the COPYING file in the main directory for details.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(USB_INCLUDES) $(WITH_INCLUDES)
+AM_CXXFLAGS = -Wall -pthread -ldl
+#AM_CXXFLAGS = -Wall -O2 -NDEBUG -pthread -ldl
+#AM_CFLAGS = -Wall -O2 -NDEBUG -pthread -ldl
+
+# Order must be preserved
+SUBDIRS = \
+ sqlite3 \
+ CommonLibs \
+ GSM \
+ Transceiver52M
+
+EXTRA_DIST = \
+ autogen.sh \
+ INSTALLATION \
+ LEGAL \
+ COPYING \
+ README
+
+
+dox: FORCE
+ doxygen doxconfig
+
+FORCE: