aboutsummaryrefslogtreecommitdiffstats
path: root/CommonLibs/Makefile.am
diff options
context:
space:
mode:
authorkurtis.heimerl <kurtis.heimerl@19bc5d8c-e614-43d4-8b26-e1612bc8e597>2013-05-31 21:47:25 +0000
committerkurtis.heimerl <kurtis.heimerl@19bc5d8c-e614-43d4-8b26-e1612bc8e597>2013-05-31 21:47:25 +0000
commit5a87247fdf2768a6408e0b87c210cebda85bc996 (patch)
treeb538e7e42f8a7ba6c53e1b0bc22bfb359b1e0ef9 /CommonLibs/Makefile.am
parentbec41039bf2ec07c04a6e8b0b586b085ab9cd74c (diff)
syncing commonlibs with Many thanks to Michael Iedema for these patches, makes config a lot better.
git-svn-id: http://wush.net/svn/range/software/public/openbts/trunk@5655 19bc5d8c-e614-43d4-8b26-e1612bc8e597
Diffstat (limited to 'CommonLibs/Makefile.am')
-rw-r--r--CommonLibs/Makefile.am28
1 files changed, 19 insertions, 9 deletions
diff --git a/CommonLibs/Makefile.am b/CommonLibs/Makefile.am
index 624ba44..26a55ed 100644
--- a/CommonLibs/Makefile.am
+++ b/CommonLibs/Makefile.am
@@ -22,7 +22,11 @@
include $(top_srcdir)/Makefile.common
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES)
-AM_CXXFLAGS = -Wall -ldl -O3 -g -lpthread
+AM_CXXFLAGS = -Wall -O3 -g -ldl -lpthread
+
+EXTRA_DIST = \
+ example.config \
+ README.common
noinst_LTLIBRARIES = libcommon.la
@@ -32,11 +36,12 @@ libcommon_la_SOURCES = \
Sockets.cpp \
Threads.cpp \
Timeval.cpp \
+ Reporting.cpp \
+ Logger.cpp \
Configuration.cpp \
sqlite3util.cpp \
- Logger.cpp \
URLEncode.cpp \
- Reporting.cpp
+ Utils.cpp
noinst_PROGRAMS = \
BitVectorTest \
@@ -47,9 +52,10 @@ noinst_PROGRAMS = \
VectorTest \
ConfigurationTest \
LogTest \
+ URLEncodeTest \
F16Test
-# ReportingTest
+# ReportingTest
noinst_HEADERS = \
BitVector.h \
@@ -60,15 +66,19 @@ noinst_HEADERS = \
Timeval.h \
Regexp.h \
Vector.h \
- URLEncode.h \
Configuration.h \
Reporting.h \
F16.h \
+ URLEncode.h \
+ Utils.h \
Logger.h \
sqlite3util.h
+URLEncodeTest_SOURCES = URLEncodeTest.cpp
+URLEncodeTest_LDADD = libcommon.la
+
BitVectorTest_SOURCES = BitVectorTest.cpp
-BitVectorTest_LDADD = libcommon.la
+BitVectorTest_LDADD = libcommon.la $(SQLITE_LA)
InterthreadTest_SOURCES = InterthreadTest.cpp
InterthreadTest_LDADD = libcommon.la
@@ -82,7 +92,7 @@ TimevalTest_SOURCES = TimevalTest.cpp
TimevalTest_LDADD = libcommon.la
VectorTest_SOURCES = VectorTest.cpp
-VectorTest_LDADD = libcommon.la
+VectorTest_LDADD = libcommon.la $(SQLITE_LA)
RegexpTest_SOURCES = RegexpTest.cpp
RegexpTest_LDADD = libcommon.la
@@ -90,8 +100,8 @@ RegexpTest_LDADD = libcommon.la
ConfigurationTest_SOURCES = ConfigurationTest.cpp
ConfigurationTest_LDADD = libcommon.la $(SQLITE_LA)
-#ReportingTest_SOURCES = ReportingTest.cpp
-#ReportingTest_LDADD = libcommon.la $(SQLITE_LA)
+# ReportingTest_SOURCES = ReportingTest.cpp
+# ReportingTest_LDADD = libcommon.la $(SQLITE_LA)
LogTest_SOURCES = LogTest.cpp
LogTest_LDADD = libcommon.la $(SQLITE_LA)