aboutsummaryrefslogtreecommitdiffstats
path: root/tests/mm_auth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/mm_auth/Makefile.am')
-rw-r--r--tests/mm_auth/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/tests/mm_auth/Makefile.am b/tests/mm_auth/Makefile.am
new file mode 100644
index 000000000..cb351988b
--- /dev/null
+++ b/tests/mm_auth/Makefile.am
@@ -0,0 +1,37 @@
+AM_CPPFLAGS = \
+ $(all_includes) \
+ -I$(top_srcdir)/include \
+ $(NULL)
+
+AM_CFLAGS = \
+ -Wall \
+ $(LIBOSMOCORE_CFLAGS) \
+ $(LIBOSMOABIS_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
+ $(LIBCRYPTO_CFLAGS) \
+ $(NULL)
+
+noinst_PROGRAMS = \
+ mm_auth_test \
+ $(NULL)
+
+EXTRA_DIST = \
+ mm_auth_test.ok \
+ $(NULL)
+
+mm_auth_test_SOURCES = \
+ mm_auth_test.c \
+ $(NULL)
+
+mm_auth_test_LDFLAGS = \
+ -Wl,--wrap=db_get_authinfo_for_subscr \
+ -Wl,--wrap=db_get_lastauthtuple_for_subscr \
+ -Wl,--wrap=db_sync_lastauthtuple_for_subscr \
+ $(NULL)
+
+mm_auth_test_LDADD = \
+ $(top_builddir)/src/libmsc/libmsc.a \
+ $(top_builddir)/src/libcommon/libcommon.a \
+ $(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(NULL)