aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am28
1 files changed, 0 insertions, 28 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 7e17ad8de..10bb916ff 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,32 +1,8 @@
SUBDIRS = \
- gsm0408 \
- channel \
gprs \
- abis \
gbproxy \
- trau \
- subscr \
- nanobts_omlattr \
- sms_queue \
- msc_vlr \
$(NULL)
-if BUILD_NAT
-SUBDIRS += \
- bsc-nat \
- bsc-nat-trie \
- $(NULL)
-endif
-if BUILD_BSC
-SUBDIRS += \
- bsc \
- $(NULL)
-endif
-if BUILD_SMPP
-SUBDIRS += \
- smpp \
- $(NULL)
-endif
if HAVE_LIBGTP
SUBDIRS += \
gtphub \
@@ -68,7 +44,6 @@ EXTRA_DIST = \
$(TESTSUITE) \
vty_test_runner.py \
ctrl_test_runner.py \
- smpp_test_runner.py \
$(NULL)
TESTSUITE = $(srcdir)/testsuite
@@ -83,9 +58,6 @@ python-tests: $(BUILT_SOURCES)
osmotestconfig.py -p $(abs_top_srcdir) -w $(abs_top_builddir) -v
$(PYTHON) $(srcdir)/vty_test_runner.py -w $(abs_top_builddir) -v
$(PYTHON) $(srcdir)/ctrl_test_runner.py -w $(abs_top_builddir) -v
-if BUILD_SMPP
- $(PYTHON) $(srcdir)/smpp_test_runner.py -w $(abs_top_builddir) -v
-endif
rm -f $(top_builddir)/sms.db $(top_builddir)/gsn_restart $(top_builddir)/gtphub_restart_count
else
python-tests: $(BUILT_SOURCES)