aboutsummaryrefslogtreecommitdiffstats
path: root/src/gprs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gprs/Makefile.am')
-rw-r--r--src/gprs/Makefile.am58
1 files changed, 0 insertions, 58 deletions
diff --git a/src/gprs/Makefile.am b/src/gprs/Makefile.am
index e5d50d375..170ded8fc 100644
--- a/src/gprs/Makefile.am
+++ b/src/gprs/Makefile.am
@@ -26,15 +26,6 @@ AM_CFLAGS += \
$(NULL)
endif
-OSMO_LIBS = \
- $(LIBOSMOCORE_LIBS) \
- $(LIBOSMOGSM_LIBS) \
- $(LIBOSMOVTY_LIBS) \
- $(LIBOSMOCTRL_LIBS) \
- $(LIBOSMOGB_LIBS) \
- $(LIBGTP_LIBS) \
- $(NULL)
-
noinst_LTLIBRARIES = libcommon.la
libcommon_la_SOURCES = \
@@ -53,52 +44,3 @@ libcommon_la_LIBADD = \
$(LIBOSMOSIGTRAN_LIBS) \
$(LIBCARES_LIBS) \
$(NULL)
-
-bin_PROGRAMS = \
- osmo-sgsn \
- $(NULL)
-
-osmo_sgsn_SOURCES = \
- gprs_gb.c \
- gprs_gmm_attach.c \
- gprs_gmm.c \
- gprs_mm_state_gb_fsm.c \
- gprs_mm_state_iu_fsm.c \
- gprs_ranap.c \
- gprs_sgsn.c \
- gprs_sndcp.c \
- gprs_sndcp_comp.c \
- gprs_sndcp_dcomp.c \
- gprs_sndcp_pcomp.c \
- gprs_sndcp_vty.c \
- gprs_sndcp_xid.c \
- sgsn_main.c \
- sgsn_vty.c \
- sgsn_libgtp.c \
- gprs_llc.c \
- gprs_llc_vty.c \
- sgsn_ctrl.c \
- sgsn_auth.c \
- gprs_subscriber.c \
- sgsn_cdr.c \
- slhc.c \
- gprs_llc_xid.c \
- v42bis.c \
- $(NULL)
-osmo_sgsn_LDADD = \
- libcommon.la \
- $(OSMO_LIBS) \
- $(LIBOSMOABIS_LIBS) \
- $(LIBOSMOGSUPCLIENT_LIBS) \
- $(LIBCARES_LIBS) \
- $(LIBGTP_LIBS) \
- -lrt \
- -lm \
- $(NULL)
-if BUILD_IU
-osmo_sgsn_LDADD += \
- $(LIBOSMOSIGTRAN_LIBS) \
- $(LIBOSMORANAP_LIBS) \
- $(LIBASN1C_LIBS) \
- $(NULL)
-endif