aboutsummaryrefslogtreecommitdiffstats
path: root/tests/gtphub/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-08-12 13:43:54 +0200
committerNeels Hofmeyr <neels@hofmeyr.de>2017-08-27 17:40:55 +0200
commit7e82b74c752a1581f7dfe0d6923293cecf062428 (patch)
tree974f43134922087eca86272f9e0f365838b3c5a1 /tests/gtphub/Makefile.am
parentdfbd2c88d2b124a2db5771ceb903422e55699149 (diff)
Migrate from gprs_apn_to_str() to libosmocore osmo_apn_to_str()
In 2015, Jacob moved/copied related functions to libosmocore, but for some reason didn't remove the copies here. Let's follow-up on that and remove duplicated code. The libosmocore commit introducing osmo_apn_to_str() was 8114294bf29ac6e44822c0ae43d4b0819f11b022 Change-Id: I7315ffcbed8a54cca2056f313bb7783ad82d0ee9
Diffstat (limited to 'tests/gtphub/Makefile.am')
-rw-r--r--tests/gtphub/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/gtphub/Makefile.am b/tests/gtphub/Makefile.am
index 5c834b782..f2a6b888e 100644
--- a/tests/gtphub/Makefile.am
+++ b/tests/gtphub/Makefile.am
@@ -8,6 +8,7 @@ AM_CFLAGS = \
-ggdb3 \
$(LIBOSMOCORE_CFLAGS) \
$(LIBOSMOABIS_CFLAGS) \
+ $(LIBOSMOGSM_CFLAGS) \
$(LIBGTP_CFLAGS) \
$(NULL)
@@ -37,6 +38,7 @@ gtphub_test_LDADD = \
$(top_builddir)/src/gprs/gtphub.o \
$(top_builddir)/src/gprs/gprs_utils.o \
$(LIBOSMOCORE_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
$(LIBGTP_LIBS) \
-lrt \
$(NULL)