aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-12-27 09:42:59 +0000
committerHolger Freyther <zecke@selfish.org>2008-12-27 09:42:59 +0000
commit5f75598c2804380ca07a5d52a411b5b64ba57fc3 (patch)
tree668e806888d49e1f32b026b5f7b83bb8c6e733d4 /src/Makefile.am
parent5677ae35ba3e4b617c590b46f0f224a15f924e5b (diff)
Introduce a simple timer API....
One can use add_timer or schedule_timer to add a timer. After the timeout time has been reached the callback will be called. One can call add_time/schedule_timer and del_timer from within the callback.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bf55f2656..6209906c2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -4,7 +4,7 @@ AM_CFLAGS=-Wall
sbin_PROGRAMS = bsc_hack db_test
bsc_hack_SOURCES = bsc_hack.c misdn.c abis_rsl.c abis_nm.c gsm_04_08.c gsm_data.c \
- gsm_subscriber.c msgb.c select.c chan_alloc.c
+ gsm_subscriber.c msgb.c select.c chan_alloc.c timer.c
db_test_SOURCES = db_test.c db.c
db_test_LDADD = -ldl -ldbi