aboutsummaryrefslogtreecommitdiffstats
path: root/openbsc/configure.ac
diff options
context:
space:
mode:
authorNeels Hofmeyr <nhofmeyr@sysmocom.de>2015-11-29 19:14:58 +0100
committerNeels Hofmeyr <nhofmeyr@sysmocom.de>2015-12-03 11:47:34 +0100
commit8defadbdd2953482ad53fe9ef37bb81ff76a2097 (patch)
treea8170fe5569a6a2d49a1600701f40a9a28604c1c /openbsc/configure.ac
parent59c1b645e2d86457ee1c9df56860aec8ee5a606f (diff)
tests: fix condition to run sgsn, oap, gtphub tests
Sponsored-by: On-Waves ehi
Diffstat (limited to 'openbsc/configure.ac')
-rw-r--r--openbsc/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/openbsc/configure.ac b/openbsc/configure.ac
index df6ca6793..0d6a1da95 100644
--- a/openbsc/configure.ac
+++ b/openbsc/configure.ac
@@ -84,6 +84,12 @@ PKG_CHECK_MODULES([LIBCARES], [libcares], [], [found_libcares=no])
AM_CONDITIONAL(HAVE_LIBCARES, test "$found_libcares" = yes)
AC_SUBST(found_libcares)
+found_libgtp_and_libcares=no
+if test "$found_libgtp" = "yes" -a "$found_libcares" = "yes"; then
+ found_libgtp_and_libcares=yes
+fi
+AC_SUBST(found_libgtp_and_libcares)
+
dnl checks for header files
AC_HEADER_STDC
AC_CHECK_HEADERS(dahdi/user.h,,AC_MSG_WARN(DAHDI input driver will not be built))