aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2012-11-06 14:44:44 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2012-11-06 23:11:43 +0100
commitf3a317ceedf59c1a53b4813ca51445f78efd9c50 (patch)
treef894a16d98ec41a20b355aa7bc49292e25b57bb8 /debian/rules
parente600eed7faf12f1f6b0bc1baab667e960adf68d5 (diff)
debian: Update the rules to work from the toplevel directory
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 34ef3e7d9..e82ba91c5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,11 +18,11 @@ DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
%:
- dh --with autoreconf $@
+ dh --sourcedirectory=openbsc --with autoreconf $@
override_dh_auto_configure:
- echo $(VERSION) > .tarball-version
- dh_auto_configure -- --enable-nat --enable-osmo-bsc
+ echo $(VERSION) > openbsc/.tarball-version
+ dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc
override_dh_auto_test:
# tests are broken...