aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorAlexander Couzens <lynxis@fe80.eu>2017-08-07 09:48:18 +0000
committerNeels Hofmeyr <neels@hofmeyr.de>2017-08-30 14:18:04 +0200
commit508c763e7f3c8511f7076f9d905125e1aa10a205 (patch)
treee2eb1aeb73f408162ff7acd206855bd68fde4d27 /debian/rules
parent0010b7e59a14e8569b337f0a6a3f4e7d764adc5b (diff)
rework /debian support to match new osmo-sgsn
Remove old leftover from split of osmo-sgsn out of openbsc. Change-Id: Ic0135a1118a115e8f053154e280f60674390f43a
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules87
1 files changed, 58 insertions, 29 deletions
diff --git a/debian/rules b/debian/rules
index 4e187a6cf..4fe1f467d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,32 +1,61 @@
#!/usr/bin/make -f
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-DEBIAN := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
-DEBVERS := $(shell echo '$(DEBIAN)' | cut -d- -f1)
-VERSION := $(shell echo '$(DEBVERS)' | sed -e 's/[+-].*//' -e 's/~//g')
-
-export DEB_BUILD_MAINT_OPTIONS = hardening=+all
-
+# You must remove unused comment lines for the released package.
+# See debhelper(7) (uncomment to enable)
+# This is an autogenerated template for debian/rules.
+#
+# Output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
+#
+# Copy some variable definitions from pkg-info.mk and vendor.mk
+# under /usr/share/dpkg/ to here if they are useful.
+#
+# See FEATURE AREAS/ENVIRONMENT in dpkg-buildflags(1)
+# Apply all hardening options
+#export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+# Package maintainers to append CFLAGS
+#export DEB_CFLAGS_MAINT_APPEND = -Wall -pedantic
+# Package maintainers to append LDFLAGS
+#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+#
+# With debhelper version 9 or newer, the dh command exports
+# all buildflags. So there is no need to include the
+# /usr/share/dpkg/buildflags.mk file here if compat is 9 or newer.
+#
+# These are rarely used code. (START)
+#
+# The following include for *.mk magically sets miscellaneous
+# variables while honoring existing values of pertinent
+# environment variables:
+#
+# Architecture-related variables such as DEB_TARGET_MULTIARCH:
+#include /usr/share/dpkg/architecture.mk
+# Vendor-related variables such as DEB_VENDOR:
+#include /usr/share/dpkg/vendor.mk
+# Package-related variables such as DEB_DISTRIBUTION
+#include /usr/share/dpkg/pkg-info.mk
+#
+# You may alternatively set them susing a simple script such as:
+# DEB_VENDOR ?= $(shell dpkg-vendor --query Vendor)
+#
+# These are rarely used code. (END)
+#
+
+# main packaging script based on dh7 syntax
%:
- dh $@ --sourcedirectory=openbsc --with autoreconf
-
-# This is needed for debian stable (squeeze)
-override_dh_autoreconf:
- cd openbsc && autoreconf --install --force
-
+ dh $@ --with autoreconf
+
+# debmake generated override targets
+# Set options for ./configure
+CONFIGURE_FLAGS += --enable-iu
+override_dh_configure:
+ dh_auto_configure -- $(CONFIGURE_FLAGS)
+#
+# Do not install libtool archive, python .pyc .pyo
+#override_dh_install:
+# dh_install --list-missing -X.la -X.pyc -X.pyo
+
+# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
override_dh_strip:
- dh_strip -posmocom-bsc --dbg-package=osmocom-bsc-dbg
- dh_strip -posmocom-nitb --dbg-package=osmocom-nitb-dbg
- dh_strip -posmocom-ipaccess-utils --dbg-package=osmocom-ipaccess-utils-dbg
- dh_strip -posmocom-bs11-utils --dbg-package=osmocom-bs11-utils-dbg
- dh_strip -posmocom-sgsn --dbg-package=osmocom-sgsn-dbg
- dh_strip -posmocom-gbproxy --dbg-package=osmocom-gbproxy-dbg
- dh_strip -posmocom-bsc-nat --dbg-package=osmocom-bsc-nat-dbg
- dh_strip -posmo-gtphub --dbg-package=osmo-gtphub-dbg
-
-override_dh_auto_configure:
- echo $(VERSION) > openbsc/.tarball-version
- dh_auto_configure --sourcedirectory=openbsc -- --enable-nat --enable-osmo-bsc --enable-smpp
-
+ dh_strip --dbg-package=osmo-sgsn-dbg
+ dh_strip --dbg-package=osmo-gtphub-dbg
+ dh_strip --dbg-package=osmo-gbproxy-dbg