aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2017-10-28 19:06:40 +0200
committerHarald Welte <laforge@gnumonks.org>2017-10-28 19:06:40 +0200
commitf1ad3882e5035dc1621611d30a3feb201117b74a (patch)
tree8e859cb86885c0d414e4b53a17b26bdfa772443c /debian/rules
parent607f95f2676414f6f87fd0e4552dc2fbf64b23cd (diff)
Debian: fix dh_strip rules for creating one -dbg per program
Before this patch, all debug symbols end up in osmo-sgsn-dbg, with osmo-{gbproxy,gtphub}-dbg being empty. Change-Id: Ib2ceecb3527855350b69d7413efe42274dc6febd
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index dbe582b33..58ea9bbe4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -56,9 +56,9 @@ override_dh_configure:
# See https://www.debian.org/doc/manuals/developers-reference/best-pkging-practices.html#bpp-dbg
override_dh_strip:
- dh_strip --dbg-package=osmo-sgsn-dbg
- dh_strip --dbg-package=osmo-gtphub-dbg
- dh_strip --dbg-package=osmo-gbproxy-dbg
+ dh_strip -posmo-sgsn --dbg-package=osmo-sgsn-dbg
+ dh_strip -posmo-gtphub --dbg-package=osmo-gtphub-dbg
+ dh_strip -posmo-gbproxy --dbg-package=osmo-gbproxy-dbg
# Print test results in case of a failure
override_dh_auto_test: