aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Willmann <dwillmann@sysmocom.de>2020-11-06 15:25:59 +0100
committerlaforge <laforge@osmocom.org>2020-11-09 10:54:14 +0000
commit58937ce3336c6ac3a720202f285bef4775751cbf (patch)
tree1dd82e9a5393634637fa0aa92c99618dc71d8253 /configure.ac
parent02f2c34f8a1fa726e3c3fa3f6e564eb18faaca88 (diff)
configure.ac: Require python3 for ext_tests
The python scripts already use #!/usr/bin/env python3 so it was pure coincidence that the tests are working. Change-Id: I96ac31e7862fe102e5baee0c2e25458ff0451a50
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 12af7e645..346e02085 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,9 +172,9 @@ AC_ARG_ENABLE([external_tests],
[Include the VTY/CTRL tests in make check [default=no]]),
[enable_ext_tests="$enableval"],[enable_ext_tests="no"])
if test "x$enable_ext_tests" = "xyes" ; then
- AC_CHECK_PROG(PYTHON2_AVAIL,python2,yes)
- if test "x$PYTHON2_AVAIL" != "xyes" ; then
- AC_MSG_ERROR([Please install python2 to run the VTY/CTRL tests.])
+ AC_CHECK_PROG(PYTHON3_AVAIL,python3,yes)
+ if test "x$PYTHON3_AVAIL" != "xyes" ; then
+ AC_MSG_ERROR([Please install python3 to run the VTY/CTRL tests.])
fi
AC_CHECK_PROG(OSMOTESTEXT_CHECK,osmotestvty.py,yes)
if test "x$OSMOTESTEXT_CHECK" != "xyes" ; then