aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPau Espin Pedrol <pespin@sysmocom.de>2018-01-07 18:24:34 +0100
committerPau Espin Pedrol <pespin@sysmocom.de>2018-01-23 16:17:21 +0100
commit54e4849877e98f7fb0e8ca0f170052e856bd60dc (patch)
tree6b8e820194942ec1f06d426d50bbced587d7c611 /configure.ac
parent25c65c3d1f39f55340180273201cf91a1d10d741 (diff)
configure.ac: Enable Wall in CFLAGS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b89c046c7..ba82eb15a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,6 +104,9 @@ AC_COMPILE_IFELSE([AC_LANG_SOURCE([char foo;])],
CFLAGS="$saved_CFLAGS"
AC_SUBST(SYMBOL_VISIBILITY)
+CPPFLAGS="$CPPFLAGS -Wall"
+CFLAGS="$CFLAGS -Wall"
+
AX_CHECK_COMPILE_FLAG([-Werror=implicit], [CFLAGS="$CFLAGS -Werror=implicit"])
AX_CHECK_COMPILE_FLAG([-Werror=maybe-uninitialized], [CFLAGS="$CFLAGS -Werror=maybe-uninitialized"])
AX_CHECK_COMPILE_FLAG([-Werror=memset-transposed-args], [CFLAGS="$CFLAGS -Werror=memset-transposed-args"])