aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am72
1 files changed, 39 insertions, 33 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 25fdab2a..8b8f31ed 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -19,7 +19,7 @@
#
AUTOMAKE_OPTIONS = subdir-objects
-AM_CPPFLAGS = -I$(top_srcdir)/include $(STD_DEFINES_AND_INCLUDES) $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGB_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOGSM_CFLAGS)
+AM_CPPFLAGS = -I$(top_srcdir)/include $(STD_DEFINES_AND_INCLUDES) $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGB_CFLAGS) $(LIBOSMOCTRL_CFLAGS) $(LIBOSMOGSM_CFLAGS) $(LIBOSMOABIS_CFLAGS) $(LIBOSMOTRAU_CFLAGS)
if ENABLE_SYSMODSP
AM_CPPFLAGS += -DENABLE_DIRECT_PHY
@@ -33,25 +33,27 @@ if ENABLE_OC2GBTS_PHY
AM_CPPFLAGS += -DENABLE_DIRECT_PHY
endif
-AM_CXXFLAGS = -Wall -ldl -pthread
-AM_LDFLAGS = -lrt
+if ENABLE_ER_E1_CCU
+AM_CPPFLAGS += -DENABLE_DIRECT_PHY
+endif
+
+AM_CXXFLAGS = -Wall
noinst_LTLIBRARIES = libgprs.la
libgprs_la_SOURCES = \
- gprs_debug.cpp \
+ alloc_algo.cpp \
+ gprs_debug.c \
csn1.c \
csn1_dec.c \
csn1_enc.c \
gsm_rlcmac.c \
gprs_bssgp_pcu.c \
gprs_bssgp_rim.c \
- gprs_rlcmac.cpp \
+ gprs_rlcmac.c \
gprs_rlcmac_sched.cpp \
gprs_rlcmac_meas.cpp \
- gprs_rlcmac_ts_alloc.cpp \
gprs_ms.c \
- gprs_ms_storage.cpp \
gprs_pcu.c \
pcu_l1_if.cpp \
pcu_vty.c \
@@ -62,9 +64,11 @@ libgprs_la_SOURCES = \
tbf.cpp \
tbf_fsm.c \
tbf_ul.cpp \
+ tbf_ul_fsm.c \
tbf_ul_ack_fsm.c \
tbf_ul_ass_fsm.c \
tbf_dl.cpp \
+ tbf_dl_fsm.c \
tbf_dl_ass_fsm.c \
bts.cpp \
bts_pch_timer.c \
@@ -73,9 +77,12 @@ libgprs_la_SOURCES = \
encoding.cpp \
sba.c \
decoding.cpp \
- llc.cpp \
+ llc.c \
rlc.cpp \
- osmobts_sock.c \
+ rlc_window.cpp \
+ rlc_window_dl.cpp \
+ rlc_window_ul.cpp \
+ pcuif_sock.c \
gprs_codel.c \
coding_scheme.c \
egprs_rlc_compression.cpp \
@@ -87,6 +94,7 @@ bin_PROGRAMS = \
noinst_PROGRAMS =
noinst_HEADERS = \
+ alloc_algo.h \
gprs_debug.h \
csn1.h \
gsm_rlcmac.h \
@@ -94,9 +102,9 @@ noinst_HEADERS = \
gprs_bssgp_rim.h \
gprs_rlcmac.h \
gprs_ms.h \
- gprs_ms_storage.h \
gprs_pcu.h \
pcu_l1_if.h \
+ pcu_l1_if_phy.h \
pcu_vty.h \
pcu_vty_functions.h \
mslot_class.h \
@@ -116,6 +124,9 @@ noinst_HEADERS = \
encoding.h \
sba.h \
rlc.h \
+ rlc_window.h \
+ rlc_window_dl.h \
+ rlc_window_ul.h \
decoding.h \
llc.h \
pcu_utils.h \
@@ -130,13 +141,6 @@ osmo_pcu_SOURCES = pcu_main.cpp
if ENABLE_SYSMODSP
AM_CPPFLAGS += -I$(srcdir)/osmo-bts-sysmo -I$(SYSMOBTS_INCDIR)
-EXTRA_DIST = \
- osmo-bts-sysmo/sysmo_l1_if.c \
- osmo-bts-sysmo/sysmo_l1_if.h \
- osmo-bts-sysmo/sysmo_l1_hw.c \
- osmo-bts-sysmo/femtobts.c \
- osmo-bts-sysmo/femtobts.h
-
noinst_HEADERS += \
osmo-bts-sysmo/sysmo_l1_if.h \
osmo-bts-sysmo/femtobts.h
@@ -161,19 +165,13 @@ osmo_pcu_remote_LDADD = \
$(LIBOSMOCORE_LIBS) \
$(LIBOSMOCTRL_LIBS) \
$(LIBOSMOGSM_LIBS) \
- $(COMMON_LA)
+ -lrt \
+ $(NULL)
endif
if ENABLE_LC15BTS_PHY
AM_CPPFLAGS += $(LITECELL15_CFLAGS) -I$(srcdir)/osmo-bts-litecell15
-EXTRA_DIST = \
- osmo-bts-litecell15/lc15_l1_if.c \
- osmo-bts-litecell15/lc15_l1_if.h \
- osmo-bts-litecell15/lc15_l1_hw.c \
- osmo-bts-litecell15/lc15bts.c \
- osmo-bts-litecell15/lc15bts.h
-
noinst_HEADERS += \
osmo-bts-litecell15/lc15_l1_if.h \
osmo-bts-litecell15/lc15bts.h
@@ -187,13 +185,6 @@ endif
if ENABLE_OC2GBTS_PHY
AM_CPPFLAGS += -I$(OC2G_INCDIR) -I$(srcdir)/osmo-bts-oc2g
-EXTRA_DIST = \
- osmo-bts-oc2g/oc2g_l1_if.c \
- osmo-bts-oc2g/oc2g_l1_if.h \
- osmo-bts-oc2g/oc2g_l1_hw.c \
- osmo-bts-oc2g/oc2gbts.c \
- osmo-bts-oc2g/oc2gbts.h
-
noinst_HEADERS += \
osmo-bts-oc2g/oc2g_l1_if.h \
osmo-bts-oc2g/oc2gbts.h
@@ -204,12 +195,27 @@ osmo_pcu_SOURCES += \
osmo-bts-oc2g/oc2gbts.c
endif
+if ENABLE_ER_E1_CCU
+AM_CPPFLAGS += -I$(srcdir)/ericsson-rbs
+
+noinst_HEADERS += \
+ ericsson-rbs/er_ccu_if.h \
+ ericsson-rbs/er_ccu_descr.h
+
+osmo_pcu_SOURCES += \
+ ericsson-rbs/er_ccu_l1_if.c \
+ ericsson-rbs/er_ccu_if.c
+endif
+
osmo_pcu_LDADD = \
libgprs.la \
$(LIBOSMOGB_LIBS) \
$(LIBOSMOCORE_LIBS) \
$(LIBOSMOCTRL_LIBS) \
$(LIBOSMOGSM_LIBS) \
- $(COMMON_LA)
+ $(LIBOSMOABIS_LIBS) \
+ $(LIBOSMOTRAU_LIBS) \
+ -lrt \
+ $(NULL)
#MOSTLYCLEANFILES += testSource testDestination