aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 19 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 6646f534..beee4c09 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -34,14 +34,22 @@ libgprs_la_SOURCES = \
gsm_rlcmac.cpp \
gprs_bssgp_pcu.cpp \
gprs_rlcmac.cpp \
- gprs_rlcmac_data.cpp \
gprs_rlcmac_sched.cpp \
gprs_rlcmac_meas.cpp \
+ gprs_rlcmac_ts_alloc.cpp \
gsm_timer.cpp \
bitvector.cpp \
pcu_l1_if.cpp \
pcu_vty.c \
- tbf.cpp
+ tbf.cpp \
+ bts.cpp \
+ poll_controller.cpp \
+ encoding.cpp \
+ ta.cpp \
+ sba.cpp \
+ decoding.cpp \
+ llc.cpp \
+ rlc.cpp
if ENABLE_SYSMOBTS
libgprs_la_SOURCES += \
@@ -74,7 +82,15 @@ noinst_HEADERS = \
pcu_vty.h \
sysmo_l1_if.h \
femtobts.h \
- tbf.h
+ tbf.h \
+ bts.h \
+ poll_controller.h \
+ encoding.h \
+ ta.h \
+ sba.h \
+ rlc.h \
+ decoding.h \
+ llc.h
osmo_pcu_SOURCES = pcu_main.cpp