aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 1 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index e23a40fd..4cbc1147 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,16 +1,5 @@
AUTOMAKE_OPTIONS = foreign dist-bzip2 1.6
-SUBDIRS = src examples
+SUBDIRS = src examples tests
EXTRA_DIST = osmoappdesc.py
-if ENABLE_VTY_TESTS
-python-tests: $(BUILT_SOURCES)
- osmotestvty.py -p $(top_srcdir) -w $(builddir) -v
- osmotestconfig.py -p $(top_srcdir) -w $(builddir) -v
-else
-python-tests: $(BUILT_SOURCES)
- @echo "Not running python-based tests (determined at configure-time)"
-endif
-
-check-local: $(BUILT_SOURCES)
- $(MAKE) $(AM_MAKEFLAGS) python-tests