aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-10-16 17:29:31 +0200
committerHolger Hans Peter Freyther <holger@moiji-mobile.com>2013-10-30 21:20:44 +0100
commitbfdd5f285b5c3577d57946886f484b9474abed77 (patch)
treefe44c8dcd29bf9638eee112252b5f99d02615ae2 /tests/Makefile.am
parent948a3d62b1bd918a71613db0a3c6489251795c70 (diff)
alloc: Add very basic test case for the alloc_a algorithm
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 88be6524..a752067b 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(LIBOSMOCORE_CFLAGS) $(LIBOSMOGB_CFLAGS) $(LIBOSMOGSM_CFLAGS) -I$(top_srcdir)/src/
-check_PROGRAMS = rlcmac/RLCMACTest
+check_PROGRAMS = rlcmac/RLCMACTest alloc/AllocTest
noinst_PROGRAMS = emu/pcu_emu
rlcmac_RLCMACTest_SOURCES = rlcmac/RLCMACTest.cpp
@@ -9,6 +9,14 @@ rlcmac_RLCMACTest_LDADD = \
$(LIBOSMOCORE_LIBS) \
$(COMMON_LA)
+alloc_AllocTest_SOURCES = alloc/AllocTest.cpp
+alloc_AllocTest_LDADD = \
+ $(top_builddir)/src/libgprs.la \
+ $(LIBOSMOGB_LIBS) \
+ $(LIBOSMOGSM_LIBS) \
+ $(LIBOSMOCORE_LIBS) \
+ $(COMMON_LA)
+
emu_pcu_emu_SOURCES = emu/pcu_emu.cpp emu/test_replay_gprs_attach.cpp \
emu/openbsc_clone.c emu/openbsc_clone.h emu/gprs_tests.h \
emu/test_pdp_activation.cpp
@@ -40,7 +48,8 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
EXTRA_DIST = \
testsuite.at $(srcdir)/package.m4 $(TESTSUITE) \
- rlcmac/RLCMACTest.ok rlcmac/RLCMACTest.err
+ rlcmac/RLCMACTest.ok rlcmac/RLCMACTest.err \
+ alloc/AllocTest.ok alloc/AllocTest.err
DISTCLEANFILES = atconfig