aboutsummaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorJacob Erlbeck <jerlbeck@sysmocom.de>2015-02-23 14:17:01 +0100
committerJacob Erlbeck <jerlbeck@sysmocom.de>2015-02-23 14:17:01 +0100
commit18fef1064162ee23fe839d4b890a6736ec54fd31 (patch)
tree93acc8522079acd97010ce78d3ff0df273fb0933 /tests/Makefile.am
parentf5c97476de68ac7ce2fba48be1e7502c1c794606 (diff)
tests: Fix library link order
Currently libgprs.la is listed after libosmocore.so which leads to link errors when compiling under Ubuntu with the system build tools (no cross compiling). This patch moves libgprs.la in front of the external libs. Sponsored-by: On-Waves ehf
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index e84f17de..683a64c6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -19,11 +19,11 @@ alloc_AllocTest_LDADD = \
tbf_TbfTest_SOURCES = tbf/TbfTest.cpp
tbf_TbfTest_LDADD = \
+ $(top_builddir)/src/libgprs.la \
$(LIBOSMOGB_LIBS) \
$(LIBOSMOGSM_LIBS) \
$(LIBOSMOCORE_LIBS) \
- $(COMMON_LA) \
- $(top_builddir)/src/libgprs.la
+ $(COMMON_LA)
emu_pcu_emu_SOURCES = emu/pcu_emu.cpp emu/test_replay_gprs_attach.cpp \
emu/openbsc_clone.c emu/openbsc_clone.h emu/gprs_tests.h \
@@ -37,11 +37,11 @@ emu_pcu_emu_LDADD = \
types_TypesTest_SOURCES = types/TypesTest.cpp
types_TypesTest_LDADD = \
+ $(top_builddir)/src/libgprs.la \
$(LIBOSMOGB_LIBS) \
$(LIBOSMOGSM_LIBS) \
$(LIBOSMOCORE_LIBS) \
- $(COMMON_LA) \
- $(top_builddir)/src/libgprs.la
+ $(COMMON_LA)
# The `:;' works around a Bash 3.2 bug when the output is not writeable.